summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-10-21 10:55:34 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-10-21 11:04:03 +0200
commitdef73d4258fa6afaa565e9fc6fc1f7ed14295bc8 (patch)
tree46be25eb589b1a8e1b7ecf8bb914660855fa3c3a /sys-libs
parentpackage.mask: masked possible fixed samba version for more testing. (diff)
downloadgentoo-def73d4258fa6afaa565e9fc6fc1f7ed14295bc8.tar.gz
gentoo-def73d4258fa6afaa565e9fc6fc1f7ed14295bc8.tar.bz2
gentoo-def73d4258fa6afaa565e9fc6fc1f7ed14295bc8.zip
sys-libs/tevent: Revbump to install tevent_internal.h for bug #592502.
Package-Manager: portage-2.3.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/tevent/tevent-0.9.31-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sys-libs/tevent/tevent-0.9.31-r1.ebuild b/sys-libs/tevent/tevent-0.9.31-r1.ebuild
new file mode 100644
index 000000000000..1b56796c1cdc
--- /dev/null
+++ b/sys-libs/tevent/tevent-0.9.31-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit waf-utils multilib-minimal python-single-r1
+
+DESCRIPTION="Samba tevent library"
+HOMEPAGE="http://tevent.samba.org/"
+SRC_URI="http://samba.org/ftp/tevent/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="python"
+
+RDEPEND=">=sys-libs/talloc-2.1.8[${MULTILIB_USEDEP}]
+ python? ( ${PYTHON_DEPS} )"
+
+DEPEND="${RDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ ${PYTHON_DEPS}
+"
+# build system does not work with python3
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ waf-utils_src_configure \
+ $(multilib_native_usex python '' '--disable-python')
+}
+
+multilib_src_compile() {
+ # need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
+ unset MAKEOPTS
+ waf-utils_src_compile
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+
+ multilib_is_native_abi && use python && python_domodule tevent.py
+}
+
+multilib_src_install_all() {
+ insinto /usr/include
+ doins tevent_internal.h
+}