summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2021-01-03 19:58:20 +0100
committerFabian Groffen <grobian@gentoo.org>2021-01-03 19:58:20 +0100
commite9a367c1fa24e219d5508a0969b7c0f4a3176479 (patch)
tree721b5de9d59656d195a5c5af021b51ba7c8037f4 /sys-libs
parentdev-lang/gforth: fix clang build (use -rdynamic) (diff)
downloadgentoo-e9a367c1fa24e219d5508a0969b7c0f4a3176479.tar.gz
gentoo-e9a367c1fa24e219d5508a0969b7c0f4a3176479.tar.bz2
gentoo-e9a367c1fa24e219d5508a0969b7c0f4a3176479.zip
sys-libs/musl: prefix sysroot, bug #755071
Closes: https://bugs.gentoo.org/755071 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/musl/musl-1.2.1-r1.ebuild4
-rw-r--r--sys-libs/musl/musl-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/sys-libs/musl/musl-1.2.1-r1.ebuild b/sys-libs/musl/musl-1.2.1-r1.ebuild
index b380f8294d34..d433abdd3397 100644
--- a/sys-libs/musl/musl-1.2.1-r1.ebuild
+++ b/sys-libs/musl/musl-1.2.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -69,7 +69,7 @@ src_configure() {
just_headers && export CC=true
local sysroot
- is_crosscompile && sysroot=/usr/${CTARGET}
+ is_crosscompile && sysroot="${EPREFIX}"/usr/${CTARGET}
./configure \
--target=${CTARGET} \
--prefix=${sysroot}/usr \
diff --git a/sys-libs/musl/musl-9999.ebuild b/sys-libs/musl/musl-9999.ebuild
index 170c94aedcf4..a4f0d0fe5f87 100644
--- a/sys-libs/musl/musl-9999.ebuild
+++ b/sys-libs/musl/musl-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -65,7 +65,7 @@ src_configure() {
just_headers && export CC=true
local sysroot
- is_crosscompile && sysroot=/usr/${CTARGET}
+ is_crosscompile && sysroot="${EPREFIX}"/usr/${CTARGET}
./configure \
--target=${CTARGET} \
--prefix=${sysroot}/usr \