summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-07-06 14:22:38 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-07-06 14:42:46 +0200
commitf4820d0562730c0e144c1bb98d2be040484cbac5 (patch)
treef072f2a563ddce77775ad5df3a5eb88e952dd7df /sys-libs
parentsys-libs/libapparmor: remove libapparmor-2.11.0-r0 (diff)
downloadgentoo-f4820d0562730c0e144c1bb98d2be040484cbac5.tar.gz
gentoo-f4820d0562730c0e144c1bb98d2be040484cbac5.tar.bz2
gentoo-f4820d0562730c0e144c1bb98d2be040484cbac5.zip
sys-libs/tevent: Bump to version 0.9.32
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/tevent/Manifest1
-rw-r--r--sys-libs/tevent/tevent-0.9.32.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/sys-libs/tevent/Manifest b/sys-libs/tevent/Manifest
index 1bd4cb71b1ef..6ef12903996c 100644
--- a/sys-libs/tevent/Manifest
+++ b/sys-libs/tevent/Manifest
@@ -1,2 +1,3 @@
DIST tevent-0.9.28.tar.gz 581522 SHA256 04d953379025b1560af5c4ffcce58a3ee84db7aaa09c9f1e3eff5b2945a13529 SHA512 328d586a5891796a731e6f0d02e1a731d3541a977c16abca355359cd7f60bbdbb0baaad49c05eb42c3a44f97e57a775605974d22d46ca6c26f283c8ca1b5a909 WHIRLPOOL 3a572a1c73d564b535b15fca06a1df1ba124cac031026a1cabcbc66e38cac374eb8dad05a25372ab66982ff3c772ed63e890b62545dcce926fa782fe5fc21147
DIST tevent-0.9.31.tar.gz 587784 SHA256 4a13f2256ad804c860e84068258bd0f8be31cf0c79aa8f3019fa32f6928c2bfc SHA512 048e37a7f5d3b8e948215fdb909c9b6e94b915c9d4978a8e18c73c9d27d5b1f179c10d19ec90325f8250e7c177c28231ad116a2975caaa43312c383e75517258 WHIRLPOOL 44061dd68b284bcaef625a70769f472ff1f2bd509843f8da9aca3c7b5affa12a825d3df49f126edc2d883bc0b1ad10eb59fba75ad80b1db12c92aeb100701fcd
+DIST tevent-0.9.32.tar.gz 590314 SHA256 d316e1438ffbb588a0afc90b748499dead25884ef275664fdca0df2793b62f8b SHA512 9bd256c245d9f82dcd5b31787c8b11780b958bef96426de231f54eaea6df680a5cf3eb8c8d066d05f271e81f303404fc4191a23a6bc2533b7d1b732b2c206fbd WHIRLPOOL 9fc88d9e946eaa3c3bd50c538b48e1f4a29e1cab8d81f7ddc81aec43b088cb931592cbf0d3cdd44c4bb0b787a7d144cf518a9b3f5e67208627aac3b7f19258e0
diff --git a/sys-libs/tevent/tevent-0.9.32.ebuild b/sys-libs/tevent/tevent-0.9.32.ebuild
new file mode 100644
index 000000000000..6a12144b62e5
--- /dev/null
+++ b/sys-libs/tevent/tevent-0.9.32.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit waf-utils multilib-minimal python-single-r1
+
+DESCRIPTION="Samba tevent library"
+HOMEPAGE="http://tevent.samba.org/"
+SRC_URI="http://samba.org/ftp/tevent/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="python"
+
+RDEPEND=">=sys-libs/talloc-2.1.9[${MULTILIB_USEDEP}]
+ python? ( ${PYTHON_DEPS} )"
+
+DEPEND="${RDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ ${PYTHON_DEPS}
+"
+# build system does not work with python3
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ waf-utils_src_configure \
+ $(multilib_native_usex python '' '--disable-python')
+}
+
+multilib_src_compile() {
+ # need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
+ unset MAKEOPTS
+ waf-utils_src_compile
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+
+ multilib_is_native_abi && use python && python_domodule tevent.py
+}
+
+multilib_src_install_all() {
+ insinto /usr/include
+ doins tevent_internal.h
+}