summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2018-04-04 09:02:47 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-08-07 23:41:19 +0200
commit7c4e5cbe228dd25b6516420cec8b2d874c111146 (patch)
treed50c9e00473f3619eef0d22cb7329ad13cbeec52 /sys-power/acpi_call/acpi_call-3.17.ebuild
parentsys-power/acpi_call: move to another upstream git repo. (diff)
downloadgentoo-7c4e5cbe228dd25b6516420cec8b2d874c111146.tar.gz
gentoo-7c4e5cbe228dd25b6516420cec8b2d874c111146.tar.bz2
gentoo-7c4e5cbe228dd25b6516420cec8b2d874c111146.zip
sys-power/acpi_call: version bump to 3.17.
Signed-off-by: Henning Schild <henning@hennsch.de>
Diffstat (limited to 'sys-power/acpi_call/acpi_call-3.17.ebuild')
-rw-r--r--sys-power/acpi_call/acpi_call-3.17.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-power/acpi_call/acpi_call-3.17.ebuild b/sys-power/acpi_call/acpi_call-3.17.ebuild
new file mode 100644
index 000000000000..b0d6197ccffa
--- /dev/null
+++ b/sys-power/acpi_call/acpi_call-3.17.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info linux-mod
+
+HOMEPAGE="https://github.com/teleshoes/acpi_call"
+if [ "${PV}" = "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="${HOMEPAGE}.git"
+ KEYWORDS=""
+else
+ inherit vcs-snapshot
+ SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A kernel module that enables you to call ACPI methods"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+CONFIG_CHECK="ACPI"
+MODULE_NAMES="acpi_call(misc:${S})"
+BUILD_TARGETS="default"
+
+PATCHES=(
+ "${FILESDIR}/${P}-linux-4.12.patch"
+ "${FILESDIR}/${P}-linux-4.14.patch"
+)
+
+src_compile(){
+ BUILD_PARAMS="KDIR=${KV_OUT_DIR} M=${S}"
+ linux-mod_src_compile
+}