summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-power/powermgmt-base
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-power/powermgmt-base')
-rw-r--r--sys-power/powermgmt-base/Manifest1
-rw-r--r--sys-power/powermgmt-base/metadata.xml8
-rw-r--r--sys-power/powermgmt-base/powermgmt-base-1.31.ebuild49
3 files changed, 58 insertions, 0 deletions
diff --git a/sys-power/powermgmt-base/Manifest b/sys-power/powermgmt-base/Manifest
new file mode 100644
index 000000000000..c834546176b5
--- /dev/null
+++ b/sys-power/powermgmt-base/Manifest
@@ -0,0 +1 @@
+DIST powermgmt-base_1.31.tar.gz 10015 SHA256 cfa68cbb381f9eeef2c4e4f50abd864e951aaa58f6ca647d8b60360cd1d22024 SHA512 deae8b227e079a73fdd3f9a6be83bdc76400d457c17d3a0881ace1fddc8785ee401beddbafad93dbf3a09b5effe5ca7c998eae69a0740a083a9e8a65c2f0af40 WHIRLPOOL f9aecd8396454462213cffb2e08c4569a2a5b9d5a513de44b473a2ebcd755cc1c4713ae51bd75ebc7ff80c069e0b28f639e981de0ab2b92eab01a3e466b57bc2
diff --git a/sys-power/powermgmt-base/metadata.xml b/sys-power/powermgmt-base/metadata.xml
new file mode 100644
index 000000000000..bc3ce8796602
--- /dev/null
+++ b/sys-power/powermgmt-base/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+ <use>
+ <flag name="pm-utils">Adds support for on_ac_power through <pkg>sys-power/pm-utils</pkg></flag>
+ </use>
+</pkgmetadata>
diff --git a/sys-power/powermgmt-base/powermgmt-base-1.31.ebuild b/sys-power/powermgmt-base/powermgmt-base-1.31.ebuild
new file mode 100644
index 000000000000..495a5c70e7bf
--- /dev/null
+++ b/sys-power/powermgmt-base/powermgmt-base-1.31.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Script to test whether computer is running on AC power"
+HOMEPAGE="http://packages.debian.org/testing/utils/powermgmt-base"
+SRC_URI="mirror://debian/pool/main/p/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ia64 ppc ppc64 x86"
+IUSE="+pm-utils"
+
+RDEPEND="!pm-utils? ( virtual/awk )
+ sys-apps/grep
+ virtual/modutils
+ pm-utils? ( >=sys-power/pm-utils-1.4.1 )"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -i \
+ -e 's:$(CC) $(CFLAGS):$(CC) $(LDFLAGS) $(CFLAGS):' \
+ src/Makefile || die
+}
+
+src_compile() {
+ tc-export CC
+ emake CFLAGS="${CFLAGS} -Wall -Wstrict-prototypes -DLINUX"
+}
+
+src_install() {
+ dodir /sbin
+ emake DESTDIR="${D}" install
+
+ doman man/{acpi,apm}_available.1
+
+ if ! use pm-utils; then
+ doman man/on_ac_power.1
+ else
+ rm -f "${D}"/sbin/on_ac_power
+ fi
+
+ newdoc debian/powermgmt-base.README.Debian README
+ dodoc debian/changelog
+}