summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>2016-12-28 16:16:35 +0200
committerGöktürk Yüksek <gokturk@gentoo.org>2016-12-28 12:53:41 -0500
commitd9b90c53eb24ddeb33dff0c8d3d7d3e1c20a6004 (patch)
tree315251e645132d11eb9e598d76c2893d26172d15 /sys-power/powerstat/powerstat-0.02.11.ebuild
parentsys-apps/less: mark alpha/arm64/hppa/m68k/s390/sh stable #603486 (diff)
downloadgentoo-d9b90c53eb24ddeb33dff0c8d3d7d3e1c20a6004.tar.gz
gentoo-d9b90c53eb24ddeb33dff0c8d3d7d3e1c20a6004.tar.bz2
gentoo-d9b90c53eb24ddeb33dff0c8d3d7d3e1c20a6004.zip
sys-power/powerstat: new ebuild
Powerstat measures the power consumption of a machine using the battery stats or the Intel RAPL interface. The output is like vmstat but also shows power consumption statistics. At the end of a run, powerstat will calculate the average, standard deviation and min/max of the gathered data. Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-power/powerstat/powerstat-0.02.11.ebuild')
-rw-r--r--sys-power/powerstat/powerstat-0.02.11.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/sys-power/powerstat/powerstat-0.02.11.ebuild b/sys-power/powerstat/powerstat-0.02.11.ebuild
new file mode 100644
index 000000000000..fb6439448b61
--- /dev/null
+++ b/sys-power/powerstat/powerstat-0.02.11.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Laptop power measuring tool"
+HOMEPAGE="https://launchpad.net/ubuntu/+source/${PN} https://github.com/ColinIanKing/${PN}"
+SRC_URI="https://github.com/ColinIanKing/${PN}/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}