summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2018-01-24 18:24:37 -0500
committerMike Frysinger <vapier@gentoo.org>2018-01-24 18:25:26 -0500
commit5356a6ae47841e901c95add5adee87dd49f2ba74 (patch)
tree5cce1d23023e10e95b91ebd43a19bdca75916912 /sys-power/powertop/powertop-9999.ebuild
parentdev-python/portend: keyworded 2.2 for ia64, bug #644088 (diff)
downloadgentoo-5356a6ae47841e901c95add5adee87dd49f2ba74.tar.gz
gentoo-5356a6ae47841e901c95add5adee87dd49f2ba74.tar.bz2
gentoo-5356a6ae47841e901c95add5adee87dd49f2ba74.zip
sys-power/powertop: only check TIMER_STATS on <linux-4.11 #629908
Closes: https://bugs.gentoo.org/629908
Diffstat (limited to 'sys-power/powertop/powertop-9999.ebuild')
-rw-r--r--sys-power/powertop/powertop-9999.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/sys-power/powertop/powertop-9999.ebuild b/sys-power/powertop/powertop-9999.ebuild
index 8d4d40d26b93..923a90555439 100644
--- a/sys-power/powertop/powertop-9999.ebuild
+++ b/sys-power/powertop/powertop-9999.ebuild
@@ -49,7 +49,6 @@ pkg_setup() {
~CPU_FREQ_GOV_ONDEMAND
~FTRACE
~BLK_DEV_IO_TRACE
- ~TIMER_STATS
~TRACING
"
ERROR_KERNEL_X86_MSR="X86_MSR is not enabled in the kernel, you almost certainly need it"
@@ -62,8 +61,7 @@ pkg_setup() {
ERROR_KERNEL_CPU_FREQ_STAT="CPU_FREQ_STAT should be enabled in the kernel for full powertop function"
ERROR_KERNEL_CPU_FREQ_GOV_ONDEMAND="CPU_FREQ_GOV_ONDEMAND should be enabled in the kernel for full powertop function"
ERROR_KERNEL_FTRACE="FTRACE needs to be turned on to enable BLK_DEV_IO_TRACE"
- ERROR_KERNEL_BLK_DEV_IO_TRACE="BLK_DEV_IO_TRACE needs to be turned on to enable TIMER_STATS, TRACING and EVENT_POWER_TRACING_DEPRECATED"
- ERROR_KERNEL_TIMER_STATS="TIMER_STATS should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_BLK_DEV_IO_TRACE="BLK_DEV_IO_TRACE needs to be turned on to enable other config options"
ERROR_KERNEL_TRACING="TRACING should be enabled in the kernel for full powertop function"
linux-info_pkg_setup
if linux_config_exists; then
@@ -88,6 +86,11 @@ pkg_setup() {
ERROR_KERNEL_PM="PM should be enabled in the kernel for full powertop function"
check_extra_config
fi
+ if kernel_is -lt 4 11; then
+ CONFIG_CHECK="~TIMER_STATS"
+ ERROR_KERNEL_TIMER_STATS="TIMER_STATS should be enabled in the kernel for full powertop function"
+ check_extra_config
+ fi
fi
}