summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-02-23 09:53:38 -0800
committerMatt Turner <mattst88@gentoo.org>2020-02-23 09:55:23 -0800
commitb345b5d0c618bdcf8626c8ca3824a5801be9aa95 (patch)
tree1976ed2bb725cc2ed27e6bc2e1fa38e619635e53 /sys-power/powertop
parentsys-apps/systemd: drop FW_LOADER_USER_HELPER_FALLBACK kernel check (diff)
downloadgentoo-b345b5d0c618bdcf8626c8ca3824a5801be9aa95.tar.gz
gentoo-b345b5d0c618bdcf8626c8ca3824a5801be9aa95.tar.bz2
gentoo-b345b5d0c618bdcf8626c8ca3824a5801be9aa95.zip
sys-power/powertop: Use tarballs from github
The 2.11 tarball has a bizarre name, and we have to run eautoreconf anyway. Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-power/powertop')
-rw-r--r--sys-power/powertop/powertop-9999.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/sys-power/powertop/powertop-9999.ebuild b/sys-power/powertop/powertop-9999.ebuild
index 165318e3ddd1..bf3642c77e9b 100644
--- a/sys-power/powertop/powertop-9999.ebuild
+++ b/sys-power/powertop/powertop-9999.ebuild
@@ -9,10 +9,8 @@ if [[ ${PV} == "9999" ]] ; then
GIT_ECLASS="git-r3"
SRC_URI=""
else
- SRC_URI="https://01.org/sites/default/files/downloads/${PN}-v${PV}.tar.gz"
+ SRC_URI="https://github.com/fenrus75/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
- MY_P="${PN}-v${PV}"
- S="${WORKDIR}/${MY_P}"
fi
inherit autotools ${GIT_ECLASS} linux-info
@@ -104,10 +102,8 @@ src_prepare() {
# Bug 599114
sed -i '1s|^|AX_REQUIRE_DEFINED([AX_CXX_COMPILE_STDCXX_11])|' configure.ac || die
- if [[ ${PV} == "9999" ]] ; then
- chmod +x scripts/version || die "Failed to make 'scripts/version' executable"
- scripts/version || die "Failed to extract version information"
- fi
+ chmod +x scripts/version || die "Failed to make 'scripts/version' executable"
+ scripts/version || die "Failed to extract version information"
eautoreconf
}