summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2020-07-10 18:23:20 +0800
committerYixun Lan <dlan@gentoo.org>2020-07-10 18:25:19 +0800
commitf8d3f1fbe28853feb0c3be19b71527ba8a1ba144 (patch)
tree5b837d0a6909d7d84b45184f3d9b39595ca84464 /sys-power/thermald
parentapp-admin/denyhosts: Revert invalid maintainer change (diff)
downloadgentoo-f8d3f1fbe28853feb0c3be19b71527ba8a1ba144.tar.gz
gentoo-f8d3f1fbe28853feb0c3be19b71527ba8a1ba144.tar.bz2
gentoo-f8d3f1fbe28853feb0c3be19b71527ba8a1ba144.zip
sys-power/thermald: version bump, 2.2
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'sys-power/thermald')
-rw-r--r--sys-power/thermald/Manifest1
-rw-r--r--sys-power/thermald/thermald-2.2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/sys-power/thermald/Manifest b/sys-power/thermald/Manifest
index aadd0c23ba33..b4ae63582db7 100644
--- a/sys-power/thermald/Manifest
+++ b/sys-power/thermald/Manifest
@@ -1,3 +1,4 @@
DIST thermald-1.9.1.tar.gz 429116 BLAKE2B 7b6105b25e89e68f82368e154b4ca2a826192d596c7427ebea3c6aa726c28b5409cf7e0f022132e2ee47423cc732a6d37b2eb05236c579e2c725820516f6993f SHA512 7c16871316fb264abad9d0182cf8b6b5c1b4c747093672e74b7db2b6aa4f322fafdf6a94bfc8a11f427f7be2ee5e5691dc6a25bb5357ce45e7afe868f89b89e1
DIST thermald-1.9.tar.gz 427380 BLAKE2B 1954531838c0fc3677ab8f91476d5670a6b5d067d580c7c570b37e5d8d8ac408cacb218531bc8363cfd56eee9331291959ff11851550c6c782a43b19bacca01a SHA512 71fa6e9fc2f55623ed0acdb65f9699d5ea2c89c4092546a73d53ac3ea3ca0a5c60f3360c8bef0af9daeeecfe9a20411d9e4d25bc1d89349cfe83ebb03ba387a8
DIST thermald-2.1.tar.gz 435310 BLAKE2B 7a5b67c2f8cb56276427188a91cc0d0c5cc7975ea847abe6eddc41b5dba77f908bc1ab97234568c65b2bcbb3bfff7881412cef2f8aa422139c64d5fb089a6511 SHA512 407d743d2799f84cd178e17ef694f0825f03db4ce80a47df95826bc26a9f142b80295905707fcba41bd5268d411a03478cd9d432545f9e2f1394d7d61539e169
+DIST thermald-2.2.tar.gz 435659 BLAKE2B 500189b924594e5b1d68adc776b3ad0c1d531d4259c65dd77f9166648c9b4273c52e1f8222254ec6500b3d37e39deb4ec862443728d50e9be95dee8e43496645 SHA512 f2c691061436699aef5bb7d9681370306dc7a64c453208911077c9a4af50e35b32247fc0a35853bb314d0e4289dd07f6116a3ade7fa278b521ed9b7b13db949b
diff --git a/sys-power/thermald/thermald-2.2.ebuild b/sys-power/thermald/thermald-2.2.ebuild
new file mode 100644
index 000000000000..b551961e47bf
--- /dev/null
+++ b/sys-power/thermald/thermald-2.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic out-of-source systemd
+
+DESCRIPTION="Thermal daemon for Intel architectures"
+HOMEPAGE="https://01.org/linux-thermal-daemon"
+SRC_URI="https://github.com/01org/thermal_daemon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/dbus-glib:=
+ dev-libs/glib:=
+ dev-libs/libxml2:=
+ sys-apps/dbus:="
+DEPEND="${RDEPEND}
+ dev-util/glib-utils"
+
+S=${WORKDIR}/thermal_daemon-${PV}
+DOCS=( thermal_daemon_usage.txt README.txt )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+my_src_configure() {
+ # bug 618948
+ append-cxxflags -std=c++14
+
+ ECONF_SOURCE="${S}" econf \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+}
+
+my_src_install_all() {
+ einstalldocs
+
+ rm -rf "${ED}"/etc/init || die
+ doinitd "${FILESDIR}"/thermald
+}