summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-11-28 16:57:09 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-11-28 16:57:09 +0100
commit70a6f0a670ea4b4f7d3fe8ac3d0d6c77320606c2 (patch)
treeeef3e3fef06f6e5481e54ea77410478b2b7ecffc /sys-power/upower/upower-0.99.7.ebuild
parentdev-python/pytest: remove 2.7.2 (diff)
downloadgentoo-70a6f0a670ea4b4f7d3fe8ac3d0d6c77320606c2.tar.gz
gentoo-70a6f0a670ea4b4f7d3fe8ac3d0d6c77320606c2.tar.bz2
gentoo-70a6f0a670ea4b4f7d3fe8ac3d0d6c77320606c2.zip
sys-power/upower: Version bump to 0.99.7
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'sys-power/upower/upower-0.99.7.ebuild')
-rw-r--r--sys-power/upower/upower-0.99.7.ebuild86
1 files changed, 86 insertions, 0 deletions
diff --git a/sys-power/upower/upower-0.99.7.ebuild b/sys-power/upower/upower-0.99.7.ebuild
new file mode 100644
index 000000000000..a884fe3466cc
--- /dev/null
+++ b/sys-power/upower/upower-0.99.7.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit ltprune systemd
+
+DESCRIPTION="D-Bus abstraction for enumerating power devices, querying history and statistics"
+HOMEPAGE="https://upower.freedesktop.org/"
+SRC_URI="https://${PN}.freedesktop.org/releases/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/3" # based on SONAME of libupower-glib.so
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+# gtk-doc files are not available as prebuilt in the tarball
+IUSE="doc +introspection ios kernel_FreeBSD kernel_linux selinux"
+
+COMMON_DEPS="
+ >=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.34:2
+ sys-apps/dbus:=
+ introspection? ( dev-libs/gobject-introspection:= )
+ kernel_linux? (
+ virtual/libusb:1
+ virtual/libgudev:=
+ virtual/udev
+ ios? (
+ >=app-pda/libimobiledevice-1:=
+ >=app-pda/libplist-1:=
+ )
+ )
+"
+RDEPEND="
+ ${COMMON_DEPS}
+ selinux? ( sec-policy/selinux-devicekit )
+"
+DEPEND="${COMMON_DEPS}
+ doc? ( dev-util/gtk-doc )
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets
+ dev-util/intltool
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+QA_MULTILIB_PATHS="usr/lib/${PN}/.*"
+
+DOCS=( AUTHORS HACKING NEWS README )
+
+src_prepare() {
+ default
+ sed -i -e '/DISABLE_DEPRECATED/d' configure || die
+}
+
+src_configure() {
+ local backend
+
+ if use kernel_linux ; then
+ backend=linux
+ elif use kernel_FreeBSD ; then
+ backend=freebsd
+ else
+ backend=dummy
+ fi
+
+ local myeconfargs=(
+ --disable-static
+ --disable-tests
+ --enable-man-pages
+ --libexecdir="${EPREFIX%/}"/usr/lib/${PN}
+ --localstatedir="${EPREFIX%/}"/var
+ --with-backend=${backend}
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ --with-systemdutildir="$(systemd_get_utildir)"
+ $(use_enable doc gtk-doc)
+ $(use_enable introspection)
+ $(use_with ios idevice)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ keepdir /var/lib/upower #383091
+ prune_libtool_files
+}