summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2021-02-17 13:57:53 -0500
committerBrian Evans <grknight@gentoo.org>2021-02-17 13:57:53 -0500
commit344ebc14273e4408c065dff7303e15fa05e3b978 (patch)
tree9219cedae530c6697479959f0e1d125493387992 /sys-power
parentsys-apps/systemd-tmpfiles: fix build on recent musl (diff)
downloadgentoo-344ebc14273e4408c065dff7303e15fa05e3b978.tar.gz
gentoo-344ebc14273e4408c065dff7303e15fa05e3b978.tar.bz2
gentoo-344ebc14273e4408c065dff7303e15fa05e3b978.zip
sys-power/acpilight: Drop old
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/acpilight/acpilight-1.2.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/sys-power/acpilight/acpilight-1.2.ebuild b/sys-power/acpilight/acpilight-1.2.ebuild
deleted file mode 100644
index 98f3c664a900..000000000000
--- a/sys-power/acpilight/acpilight-1.2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_7 )
-
-inherit python-r1 udev
-
-MY_P="${PN}-v${PV}"
-
-DESCRIPTION="Replacement for xbacklight that uses the ACPI interface to set brightness"
-HOMEPAGE="https://gitlab.com/wavexx/acpilight/"
-SRC_URI="https://gitlab.com/wavexx/acpilight/-/archive/v${PV}/${MY_P}.tar.gz"
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-S="${WORKDIR}/${MY_P}"
-
-RDEPEND="virtual/udev
- acct-group/video
- ${PYTHON_DEPS}
- !x11-apps/xbacklight"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-DOCS=( README.rst NEWS.rst )
-
-# Disable Makefile that installs by default
-src_compile() { :; }
-
-src_install() {
- python_foreach_impl python_doscript xbacklight
- udev_dorules "${S}"/90-backlight.rules
- doman xbacklight.1
- einstalldocs
- newinitd "${FILESDIR}"/acpilight.initd acpilight
- newconfd "${FILESDIR}"/acpilight.confd acpilight
-}
-
-pkg_postinst() {
- udev_reload
- einfo
- elog "To use the xbacklight binary as a regular user, you must be a part of the video group"
- einfo
- elog "If this utility does not find any backlights to manipulate,"
- elog "verify you have kernel support on the device and display driver enabled."
- einfo
- elog "To take advantage of the OpenRC init script, and automate the process of"
- elog "saving and restoring the brightness level you should add acpilight"
- elog "to the boot runlevel. You can do this as root like so:"
- elog "# rc-update add acpilight boot"
- einfo
-}