summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-11-18 12:59:22 -0500
committerMatt Turner <mattst88@gentoo.org>2022-11-18 13:00:00 -0500
commit586a0333a5703eb759fa8472faf947074b3a74d0 (patch)
tree0ae0bd709d209127fdebbc732144334c6dbc051d /sys-power
parentsys-fs/lvm2: fix strerror_r check for musl (diff)
downloadgentoo-586a0333a5703eb759fa8472faf947074b3a74d0.tar.gz
gentoo-586a0333a5703eb759fa8472faf947074b3a74d0.tar.bz2
gentoo-586a0333a5703eb759fa8472faf947074b3a74d0.zip
sys-power/powertop: Drop IUSE=unicode
- and add append-lfs-flags Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/powertop/powertop-2.15.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-power/powertop/powertop-2.15.ebuild b/sys-power/powertop/powertop-2.15.ebuild
index 4398073e6d2e..4833a907c70d 100644
--- a/sys-power/powertop/powertop-2.15.ebuild
+++ b/sys-power/powertop/powertop-2.15.ebuild
@@ -13,19 +13,19 @@ else
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
fi
-inherit autotools ${GIT_ECLASS} linux-info
+inherit autotools ${GIT_ECLASS} flag-o-matic linux-info
DESCRIPTION="tool to diagnose issues with power consumption and power management"
HOMEPAGE="https://01.org/powertop/ https://github.com/fenrus75/powertop/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="nls unicode X"
+IUSE="nls X"
DEPEND="
dev-libs/libnl:3
sys-apps/pciutils
- sys-libs/ncurses:=[unicode(+)?]
+ sys-libs/ncurses:=[unicode(+)]
"
BDEPEND="
@@ -108,6 +108,6 @@ src_prepare() {
}
src_configure() {
- export ac_cv_search_delwin=$(usex unicode -lncursesw -lncurses)
+ append-lfs-flags
econf $(use_enable nls)
}