summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2020-08-26 11:01:52 +0800
committerYixun Lan <dlan@gentoo.org>2020-08-26 11:01:52 +0800
commit939909df0badb1ae693ee9de5a5443a47c8565c3 (patch)
treef8fb9d60e21f466f88e3262425319c271defc87a /sys-power
parentdev-util/perf: drop old (diff)
downloadgentoo-939909df0badb1ae693ee9de5a5443a47c8565c3.tar.gz
gentoo-939909df0badb1ae693ee9de5a5443a47c8565c3.tar.bz2
gentoo-939909df0badb1ae693ee9de5a5443a47c8565c3.zip
sys-power/thermald: version bump, 2.3
Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/thermald/Manifest1
-rw-r--r--sys-power/thermald/thermald-2.3.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/sys-power/thermald/Manifest b/sys-power/thermald/Manifest
index ceb276678f7b..d4130b9f9a13 100644
--- a/sys-power/thermald/Manifest
+++ b/sys-power/thermald/Manifest
@@ -1,3 +1,4 @@
DIST thermald-1.9.1.tar.gz 429116 BLAKE2B 7b6105b25e89e68f82368e154b4ca2a826192d596c7427ebea3c6aa726c28b5409cf7e0f022132e2ee47423cc732a6d37b2eb05236c579e2c725820516f6993f SHA512 7c16871316fb264abad9d0182cf8b6b5c1b4c747093672e74b7db2b6aa4f322fafdf6a94bfc8a11f427f7be2ee5e5691dc6a25bb5357ce45e7afe868f89b89e1
DIST thermald-2.1.tar.gz 435310 BLAKE2B 7a5b67c2f8cb56276427188a91cc0d0c5cc7975ea847abe6eddc41b5dba77f908bc1ab97234568c65b2bcbb3bfff7881412cef2f8aa422139c64d5fb089a6511 SHA512 407d743d2799f84cd178e17ef694f0825f03db4ce80a47df95826bc26a9f142b80295905707fcba41bd5268d411a03478cd9d432545f9e2f1394d7d61539e169
DIST thermald-2.2.tar.gz 435659 BLAKE2B 500189b924594e5b1d68adc776b3ad0c1d531d4259c65dd77f9166648c9b4273c52e1f8222254ec6500b3d37e39deb4ec862443728d50e9be95dee8e43496645 SHA512 f2c691061436699aef5bb7d9681370306dc7a64c453208911077c9a4af50e35b32247fc0a35853bb314d0e4289dd07f6116a3ade7fa278b521ed9b7b13db949b
+DIST thermald-2.3.tar.gz 452790 BLAKE2B caef87d670b14bfa0dbe6ca4873ebea4b0a9960a9bad48ddb10abb348e25cafdbdf5dad831a1c3ad38e71ab61d7f123df99046dec1e5ce2c32be506bc4b1312f SHA512 0d722c35e3638bb917994b8a123e1226b737b120f0946cfc604eb3bb4bd501121b1f196833f8cb3aceee73a8bb3566ef1d176d81143b84423f89d20966e91ed8
diff --git a/sys-power/thermald/thermald-2.3.ebuild b/sys-power/thermald/thermald-2.3.ebuild
new file mode 100644
index 000000000000..eedfec46f292
--- /dev/null
+++ b/sys-power/thermald/thermald-2.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic out-of-source systemd
+
+DESCRIPTION="Thermal daemon for Intel architectures"
+HOMEPAGE="https://01.org/linux-thermal-daemon"
+SRC_URI="https://github.com/01org/thermal_daemon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/dbus-glib:=
+ dev-libs/glib:=
+ dev-libs/libxml2:=
+ sys-power/upower
+ sys-apps/dbus:="
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc
+ dev-util/glib-utils"
+
+S=${WORKDIR}/thermal_daemon-${PV}
+DOCS=( thermal_daemon_usage.txt README.txt )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+my_src_configure() {
+ # bug 618948
+ append-cxxflags -std=c++14
+
+ ECONF_SOURCE="${S}" econf \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+}
+
+my_src_install_all() {
+ einstalldocs
+
+ rm -rf "${ED}"/etc/init || die
+ doinitd "${FILESDIR}"/thermald
+}