summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-02-27 15:30:44 +0100
committerPacho Ramos <pacho@gentoo.org>2023-02-27 15:30:44 +0100
commitaed2097130e19618bb971068565d9406ad6f1c69 (patch)
tree7332be3c743e0dfafb59fdedcfefc4a2c5c98679 /sys-power
parentprofiles: mask sys-power/dptfxtract for removal (diff)
downloadgentoo-aed2097130e19618bb971068565d9406ad6f1c69.tar.gz
gentoo-aed2097130e19618bb971068565d9406ad6f1c69.tar.bz2
gentoo-aed2097130e19618bb971068565d9406ad6f1c69.zip
sys-power/switcheroo-control: drop 2.6, 2.6-r1
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/switcheroo-control/switcheroo-control-2.6-r1.ebuild64
-rw-r--r--sys-power/switcheroo-control/switcheroo-control-2.6.ebuild53
2 files changed, 0 insertions, 117 deletions
diff --git a/sys-power/switcheroo-control/switcheroo-control-2.6-r1.ebuild b/sys-power/switcheroo-control/switcheroo-control-2.6-r1.ebuild
deleted file mode 100644
index b89e15d6d645..000000000000
--- a/sys-power/switcheroo-control/switcheroo-control-2.6-r1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit meson python-any-r1 systemd
-
-DESCRIPTION="D-Bus service to check the availability of dual-GPU"
-HOMEPAGE="https://gitlab.freedesktop.org/hadess/switcheroo-control/"
-SRC_URI="https://gitlab.freedesktop.org/hadess/switcheroo-control/uploads/86ea54ac7ddb901b6bf6e915209151f8/${P}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="gtk-doc test"
-
-KEYWORDS="amd64"
-
-RDEPEND="
- >=dev-libs/glib-2.56.0:2
- >=dev-libs/libgudev-232:=
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-util/gdbus-codegen
- gtk-doc? ( dev-util/gtk-doc )
- test? (
- $(python_gen_any_dep 'dev-python/python-dbusmock[${PYTHON_USEDEP}]')
- dev-util/umockdev
- )
-"
-
-RESTRICT="!test? ( test )"
-
-python_check_deps() {
- use test || return 0
- python_has_version "dev-python/python-dbusmock[${PYTHON_USEDEP}]"
-}
-
-src_configure() {
- local emesonargs=(
- -Dsystemdsystemunitdir="$(systemd_get_systemunitdir)"
- $(meson_use gtk-doc gtk_doc)
- $(meson_use test tests)
- )
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
- python_fix_shebang "${D}"/usr/bin/switcherooctl
- newinitd "${FILESDIR}"/${PN}-init.d ${PN}
-}
-
-pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- elog "You to enable the service:"
- if systemd_is_booted; then
- elog "# systemctl enable switcheroo-control"
- else
- elog "# rc-update add ${PN} default"
- fi
- fi
-}
diff --git a/sys-power/switcheroo-control/switcheroo-control-2.6.ebuild b/sys-power/switcheroo-control/switcheroo-control-2.6.ebuild
deleted file mode 100644
index b4d8bf68db8f..000000000000
--- a/sys-power/switcheroo-control/switcheroo-control-2.6.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit meson python-any-r1
-
-DESCRIPTION="D-Bus service to check the availability of dual-GPU"
-HOMEPAGE="https://gitlab.freedesktop.org/hadess/switcheroo-control/"
-SRC_URI="https://gitlab.freedesktop.org/hadess/switcheroo-control/uploads/86ea54ac7ddb901b6bf6e915209151f8/${P}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="gtk-doc test"
-
-KEYWORDS="amd64"
-
-RDEPEND="
- >=dev-libs/glib-2.56.0:2
- >=dev-libs/libgudev-232:=
- sys-apps/systemd
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- gtk-doc? ( dev-util/gtk-doc )
- test? (
- $(python_gen_any_dep 'dev-python/python-dbusmock[${PYTHON_USEDEP}]')
- dev-util/umockdev
- )
-"
-
-RESTRICT="!test? ( test )"
-
-python_check_deps() {
- use test || return 0
- python_has_version "dev-python/python-dbusmock[${PYTHON_USEDEP}]"
-}
-
-src_configure() {
- local emesonargs=(
- $(meson_use gtk-doc gtk_doc)
- $(meson_use test tests)
- )
- meson_src_configure
-}
-
-pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- elog "You need to run systemd and enable the service:"
- elog "# systemctl enable switcheroo-control"
- fi
-}