summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-01-17 14:02:54 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-01-17 14:07:18 +0100
commitb766634896d5a6d49c6c068ff54117bf1de4cfa7 (patch)
tree33493617aab3501d04f74133226a5273e469e81b /sys-power
parentsys-power/acpi_call: bump to version 1.2.1 (diff)
downloadgentoo-b766634896d5a6d49c6c068ff54117bf1de4cfa7.tar.gz
gentoo-b766634896d5a6d49c6c068ff54117bf1de4cfa7.tar.bz2
gentoo-b766634896d5a6d49c6c068ff54117bf1de4cfa7.zip
sys-power/acpi_call: update live ebuild
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/acpi_call/acpi_call-9999.ebuild32
1 files changed, 18 insertions, 14 deletions
diff --git a/sys-power/acpi_call/acpi_call-9999.ebuild b/sys-power/acpi_call/acpi_call-9999.ebuild
index ba87b06a3dcf..ba449334ffc0 100644
--- a/sys-power/acpi_call/acpi_call-9999.ebuild
+++ b/sys-power/acpi_call/acpi_call-9999.ebuild
@@ -1,24 +1,18 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit linux-info linux-mod
+inherit git-r3 linux-info linux-mod
-HOMEPAGE="https://github.com/teleshoes/acpi_call"
-if [ "${PV}" = "9999" ]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/teleshoes/acpi_call.git"
- KEYWORDS=""
-else
- SRC_URI="https://github.com/teleshoes/acpi_call/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
+DESCRIPTION="A linux kernel module that enables calls to ACPI"
+HOMEPAGE="https://github.com/nix-community/acpi_call"
+EGIT_REPO_URI="https://github.com/teleshoes/acpi_call.git"
-DESCRIPTION="A kernel module that enables you to call ACPI methods"
-
-LICENSE="GPL-2"
+LICENSE="GPL-3+"
SLOT="0"
+KEYWORDS=""
+IUSE="examples"
BUILD_TARGETS="default"
CONFIG_CHECK="ACPI"
@@ -26,5 +20,15 @@ MODULE_NAMES="acpi_call(misc:${S})"
src_compile() {
BUILD_PARAMS="KDIR=${KV_OUT_DIR} M=${S}"
+
linux-mod_src_compile
}
+
+src_install() {
+ linux-mod_src_install
+
+ if use examples; then
+ insinto /usr/share/acpi_call
+ doins examples/*.sh
+ fi
+}