summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJay Faulkner <jay@jvf.cc>2022-09-14 18:15:52 -0700
committerSam James <sam@gentoo.org>2022-10-13 00:38:38 +0100
commitbce5e1909085a0bc5ccc307e2d8b97884b0e8ae1 (patch)
tree06fa14f9dd27fe14a613130a872c20637ca3120e /sys-power
parentdev-vcs/git-filter-repo: drop 2.33.0-r1 (diff)
downloadgentoo-bce5e1909085a0bc5ccc307e2d8b97884b0e8ae1.tar.gz
gentoo-bce5e1909085a0bc5ccc307e2d8b97884b0e8ae1.tar.bz2
gentoo-bce5e1909085a0bc5ccc307e2d8b97884b0e8ae1.zip
sys-power/tlp: new package, add 1.5.0
This is a direct import from ::guru, with the only changes being to metadata.xml to propose myself as proxy maintainer. Signed-off-by: Jay Faulkner <jay@jvf.cc> Closes: https://github.com/gentoo/gentoo/pull/27260 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/tlp/Manifest1
-rw-r--r--sys-power/tlp/files/tlp.init28
-rw-r--r--sys-power/tlp/metadata.xml23
-rw-r--r--sys-power/tlp/tlp-1.5.0.ebuild50
4 files changed, 102 insertions, 0 deletions
diff --git a/sys-power/tlp/Manifest b/sys-power/tlp/Manifest
new file mode 100644
index 000000000000..5cddbd3add64
--- /dev/null
+++ b/sys-power/tlp/Manifest
@@ -0,0 +1 @@
+DIST tlp-1.5.0.tar.gz 126447 BLAKE2B cdd2a5d094d1146a534de07cc646fd428a97f8d40c3d4ed5ec0522848ebe3a4182e36617854feeab7fa8923f7e7ef6797623a09609fdfa2a2b5dda321b188b31 SHA512 93be83f276b902467049160c20a546cdf2f0ec221274bbb4761bf89a8da09f10a494ce2f36379ef9be48ca2e7325de8e582f5dbb823e2ddd339366bae1228122
diff --git a/sys-power/tlp/files/tlp.init b/sys-power/tlp/files/tlp.init
new file mode 100644
index 000000000000..f50de9029e7b
--- /dev/null
+++ b/sys-power/tlp/files/tlp.init
@@ -0,0 +1,28 @@
+#!/sbin/openrc-run
+command=/usr/sbin/tlp
+name="TLP"
+extra_started_commands="reload stat"
+
+depend() {
+ need udev
+}
+
+start() {
+ ebegin "Starting tlp..."
+ $command init start
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading tlp's configuration..."
+ $command start
+ eend $?
+}
+
+stop() {
+ elog "Reboot to stop tlp."
+}
+
+stat() {
+ /usr/bin/tlp-stat
+}
diff --git a/sys-power/tlp/metadata.xml b/sys-power/tlp/metadata.xml
new file mode 100644
index 000000000000..d7cf4d588720
--- /dev/null
+++ b/sys-power/tlp/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>jay@jvf.cc</email>
+ <name>Jay Faulkner</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>duje.mihanovic@skole.hr</email>
+ <name>Duje Mihanović</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ TLP is a command line utility for Linux to optimize laptop battery life. Primarily by tweaking
+ kernel settings that affect power consumption.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">linrunner/TLP</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-power/tlp/tlp-1.5.0.ebuild b/sys-power/tlp/tlp-1.5.0.ebuild
new file mode 100644
index 000000000000..8eb8387f0e60
--- /dev/null
+++ b/sys-power/tlp/tlp-1.5.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit udev optfeature
+
+DESCRIPTION="Optimize laptop battery life"
+
+HOMEPAGE="https://linrunner.de/tlp/"
+
+SRC_URI="https://github.com/linrunner/TLP/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/TLP-${PV}"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+# It's uncertain if elogind/systemd is actually required, however, without the sleep
+# hooks working, which require one of them, it doesn't seem like this app is very useful.
+RDEPEND="virtual/udev
+ dev-lang/perl
+ || ( sys-auth/elogind sys-apps/systemd )"
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ TLP_NO_INIT=1 \
+ TLP_WITH_ELOGIND=1 \
+ TLP_WITH_SYSTEMD=1 \
+ install install-man
+
+ fperms 444 "/usr/share/tlp/defaults.conf" # manpage says this file should not be edited
+ newinitd "${FILESDIR}/tlp.init" tlp
+ keepdir "/var/lib/tlp" # created by Makefile, probably important
+}
+
+pkg_postinst() {
+ udev_reload
+
+ optfeature "disable Wake-on-LAN" sys-apps/ethtool
+ optfeature "see disk drive health info in tlp-stat" sys-apps/smartmontools
+}
+
+pkg_postrm() {
+ udev_reload
+}