summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-03-27 20:55:40 -0700
committerMatt Turner <mattst88@gentoo.org>2019-03-27 20:59:59 -0700
commitbe542cccd3ab6a1dcdfb954829c1717ddd8685e0 (patch)
tree366145f2255bff8cdbb3f99f29552072f97860cd /sys-power
parentnet-analyzer/zabbix: Bump zabbix 3.0.26 (diff)
downloadgentoo-be542cccd3ab6a1dcdfb954829c1717ddd8685e0.tar.gz
gentoo-be542cccd3ab6a1dcdfb954829c1717ddd8685e0.tar.bz2
gentoo-be542cccd3ab6a1dcdfb954829c1717ddd8685e0.zip
sys-power/powertop: Use pregenerated tarball
The SRC_URI in v2.9 didn't work for v2.10 so I mistakely thought they'd just switched to github-generated tarballs. Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/powertop/Manifest2
-rw-r--r--sys-power/powertop/powertop-2.10.ebuild10
-rw-r--r--sys-power/powertop/powertop-9999.ebuild10
3 files changed, 15 insertions, 7 deletions
diff --git a/sys-power/powertop/Manifest b/sys-power/powertop/Manifest
index 97496d051b44..a75203dd1ab1 100644
--- a/sys-power/powertop/Manifest
+++ b/sys-power/powertop/Manifest
@@ -1,3 +1,3 @@
-DIST powertop-2.10.tar.gz 296409 BLAKE2B 50a8881e8fedd66d144b6929bf077710050da264d1ff02f38bf5497b80d1038ee55434e3f731a970b92748ce3130a226ec85daf2f105fb10dcebd40355294c79 SHA512 ce7b5c4a5c80596c6a78f1c00c107a13dd3f0d9051c7c44333d18a0f0c050c8e148c8b251d59bd49341f20a6a19eb1f956902e8c57110251e9e4f608e0542357
DIST powertop-2.8.tar.gz 670000 BLAKE2B 4259f462d36fe0cbb157859d6e1d3e1face67f7232fe8d4112d77f844b545f49e9cf486e21bcbc34f64ffb0c891c1864141784dde14e3a96647d6535641a840a SHA512 253d0e15f0972cf8639735c510f4884d49a0da76c31dd2f39603e2297e6c6f0b9fa283c7b3cb04a431c91f8296275c0adaecc4c3e9ea132c0c31064f7f432c80
+DIST powertop-v2.10.tar.gz 722992 BLAKE2B 573f1f0ed40705d3463f6e6f76c67ae99127ab2541b851143dafa707ef1c2dab4127d27811b63ad27e6b002ea4efd39417297a0227996ad9b01141b6de733d41 SHA512 4219e7aadbeebdf6932c04f784434e4dd0f540bf4941d43c1830b1b5cad1f3928769b13897e24dd956b6bdee65fb1fbe902ee30685bca229b71e140d65367837
DIST powertop-v2.9.tar.gz 718763 BLAKE2B bb6ce789614397b02f0e9f1cb71585cb456c1428cc43e9fe1c4b3bc9f96171fede4c587410e78e58ad8d0b0f772549a93f454bcd1b521e6dd3c809a85dc3cf30 SHA512 783af538c44e3fae7215a5b4247eb32a72e02150b3f297e6b9777a450823dd30aca014601892c0e80937a366eed95b42b622c68161d53e905ad4fbcb574b26f5
diff --git a/sys-power/powertop/powertop-2.10.ebuild b/sys-power/powertop/powertop-2.10.ebuild
index 200e2c08f9f3..27089b70cb74 100644
--- a/sys-power/powertop/powertop-2.10.ebuild
+++ b/sys-power/powertop/powertop-2.10.ebuild
@@ -9,8 +9,10 @@ if [[ ${PV} == "9999" ]] ; then
GIT_ECLASS="git-r3"
SRC_URI=""
else
- SRC_URI="https://github.com/fenrus75/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://01.org/sites/default/files/downloads/${PN}-v${PV}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+ MY_P="${PN}-v${PV}"
+ S="${WORKDIR}/${MY_P}"
fi
inherit autotools ${GIT_ECLASS} linux-info
@@ -106,8 +108,10 @@ src_prepare() {
# Bug 599114
sed -i '1s|^|AX_REQUIRE_DEFINED([AX_CXX_COMPILE_STDCXX_11])|' configure.ac || die
- chmod +x scripts/version || die "Failed to make 'scripts/version' executable"
- scripts/version || die "Failed to extract version information"
+ if [[ ${PV} == "9999" ]] ; then
+ chmod +x scripts/version || die "Failed to make 'scripts/version' executable"
+ scripts/version || die "Failed to extract version information"
+ fi
eautoreconf
}
diff --git a/sys-power/powertop/powertop-9999.ebuild b/sys-power/powertop/powertop-9999.ebuild
index bf3642c77e9b..165318e3ddd1 100644
--- a/sys-power/powertop/powertop-9999.ebuild
+++ b/sys-power/powertop/powertop-9999.ebuild
@@ -9,8 +9,10 @@ if [[ ${PV} == "9999" ]] ; then
GIT_ECLASS="git-r3"
SRC_URI=""
else
- SRC_URI="https://github.com/fenrus75/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://01.org/sites/default/files/downloads/${PN}-v${PV}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+ MY_P="${PN}-v${PV}"
+ S="${WORKDIR}/${MY_P}"
fi
inherit autotools ${GIT_ECLASS} linux-info
@@ -102,8 +104,10 @@ src_prepare() {
# Bug 599114
sed -i '1s|^|AX_REQUIRE_DEFINED([AX_CXX_COMPILE_STDCXX_11])|' configure.ac || die
- chmod +x scripts/version || die "Failed to make 'scripts/version' executable"
- scripts/version || die "Failed to extract version information"
+ if [[ ${PV} == "9999" ]] ; then
+ chmod +x scripts/version || die "Failed to make 'scripts/version' executable"
+ scripts/version || die "Failed to extract version information"
+ fi
eautoreconf
}