summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-04-26 00:25:03 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-04-26 00:26:54 +0200
commitafae0000d6179d77a0a6564b56ceefdd63ba8273 (patch)
treee64dae69c033751dacfa56434aa8b3e816b0ad88 /sys-process/at
parentapp-eselect/eselect-emacs: EAPI 7 (diff)
downloadgentoo-afae0000d6179d77a0a6564b56ceefdd63ba8273.tar.gz
gentoo-afae0000d6179d77a0a6564b56ceefdd63ba8273.tar.bz2
gentoo-afae0000d6179d77a0a6564b56ceefdd63ba8273.zip
sys-process/at: Bump to version 3.2.2
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-process/at')
-rw-r--r--sys-process/at/Manifest1
-rw-r--r--sys-process/at/at-3.2.2.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/sys-process/at/Manifest b/sys-process/at/Manifest
index c7b41635cae7..6b4f5d76c066 100644
--- a/sys-process/at/Manifest
+++ b/sys-process/at/Manifest
@@ -1,2 +1,3 @@
DIST at_3.1.23.orig.tar.gz 126284 BLAKE2B b2af9dfa4ed87ee93489b98acae6b7eb005d6db7e2401ec7d4d21353af636b232d57e92e4cd6e81f52115aa9d29fadf440809a9d77cb1eb5d40d42ec7fe640b0 SHA512 ee5cf5abf32cf1e89746e427d1cc20005ef49fad47db55512c90042a77e86b2c15f5de029c79573bc86ce4aead6ed2d561b89812510aadbc5763f9288b467cfd
DIST at_3.2.1.orig.tar.gz 127577 BLAKE2B 4e8f4aa889075dcede894062b2926afd7892ef15d4ca5bf855b699d1dab9f49a56fd5bd8da376b178032e70cdef72eba2a7d9d6da577982773351633ce85d003 SHA512 8109b2acf220ffc14ea78e7d5671507e8cad41a163c1d7f96de18aae05c8617071c6306e04446450190f492a65ca31f51ed040fba5719b67625a58f738fc9c9e
+DIST at_3.2.2.orig.tar.gz 127677 BLAKE2B f4b0e1cd09d1e679d0bcc287462300827d12663927dce1534a74bd4ecd670f903a81cd6147c03b0e55192655c2a99250c27ad0e9892342d91b0279210fb79a64 SHA512 e6f5aeddd89438aadff627d654ebc821a0b0e1a600ebaacc8a5fd3ec2c7c716f593757d00501311736d28f6d4276899667d6901d70836af208ff7d181b5b680f
diff --git a/sys-process/at/at-3.2.2.ebuild b/sys-process/at/at-3.2.2.ebuild
new file mode 100644
index 000000000000..ec5f18b84236
--- /dev/null
+++ b/sys-process/at/at-3.2.2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic pam user systemd
+
+MY_P="${PN}_${PV}"
+
+DESCRIPTION="Queues jobs for later execution"
+HOMEPAGE="http://blog.calhariz.com/index.php/tag/at https://packages.qa.debian.org/a/at.html"
+SRC_URI="http://software.calhariz.com/at/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/a/at/${MY_P}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="pam selinux"
+
+DEPEND="virtual/mta
+ >=sys-devel/autoconf-2.64
+ sys-devel/bison
+ >=sys-devel/flex-2.5.4a
+ pam? ( sys-libs/pam )"
+RDEPEND="virtual/mta
+ virtual/logger
+ selinux? ( sec-policy/selinux-at )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.8-more-deny.patch
+ "${FILESDIR}"/${PN}-3.1.14-Makefile.patch
+ # fix parallel make issues, bug #244884
+ "${FILESDIR}"/${PN}-3.1.10.2-Makefile.in-parallel-make-fix.patch
+ "${FILESDIR}"/${PN}-3.1.13-configure.in-fix-PAM-automagick-dep.patch
+ # Fix parallel make issue (bug #408375)
+ "${FILESDIR}"/${PN}-3.1.13-parallel-make-fix.patch
+ "${FILESDIR}"/${PN}-3.1.13-getloadavg.patch
+)
+
+pkg_setup() {
+ # Cannot be moved into pkg_preinst!
+ enewgroup at 25
+ enewuser at 25 -1 /var/spool/at/atjobs at
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local my_conf=(
+ --sysconfdir="${EPREFIX}"/etc/at
+ --with-jobdir="${EPREFIX}"/var/spool/at/atjobs
+ --with-atspool="${EPREFIX}"/var/spool/at/atspool
+ --with-etcdir="${EPREFIX}"/etc/at
+ --with-daemon_username=at
+ --with-daemon_groupname=at
+ $(usex pam '' --without-pam)
+ $(use_with selinux)
+ )
+ econf ${my_conf[@]}
+}
+
+src_install() {
+ emake install IROOT="${D}"
+
+ newinitd "${FILESDIR}"/atd.rc8 atd
+ newconfd "${FILESDIR}"/atd.confd atd
+
+ if use pam; then
+ newpamd "${FILESDIR}"/at.pamd-3.1.13-r1 atd
+ fi
+
+ # Preserve existing .SEQ files (bug #386625)
+ local seq_file="${EROOT}/var/spool/at/atjobs/.SEQ"
+ if [[ -f "${seq_file}" ]] ; then
+ einfo "Preserving existing .SEQ file (bug #386625)."
+ cp -p "${seq_file}" "${ED}"/var/spool/at/atjobs/ || die
+ fi
+
+ systemd_dounit "${FILESDIR}/atd.service"
+ keepdir /var/spool/at/atspool
+}
+
+pkg_postinst() {
+ einfo "Forcing correct permissions on /var/spool/at"
+ local atspooldir="${EROOT}/var/spool/at"
+ chown at:at "${atspooldir}/atjobs"
+ chmod 1770 "${atspooldir}/atjobs"
+ chown at:at "${atspooldir}/atjobs/.SEQ"
+ chmod 0600 "${atspooldir}/atjobs/.SEQ"
+ chown at:at "${atspooldir}/atspool"
+ chmod 1770 "${atspooldir}/atspool"
+}