summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-03 02:06:58 +0000
committerSam James <sam@gentoo.org>2021-11-03 02:06:58 +0000
commit387fe7923e63b7722a7d7ab644533530da7baccd (patch)
treef3ee2410defd611c26c46ff30db914fb20d190ce /sys-process/audit
parentsys-process/audit: add github upstream metadata (diff)
downloadgentoo-387fe7923e63b7722a7d7ab644533530da7baccd.tar.gz
gentoo-387fe7923e63b7722a7d7ab644533530da7baccd.tar.bz2
gentoo-387fe7923e63b7722a7d7ab644533530da7baccd.zip
sys-process/audit: enable py3.10 and disable py3.7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process/audit')
-rw-r--r--sys-process/audit/audit-3.0.6.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sys-process/audit/audit-3.0.6.ebuild b/sys-process/audit/audit-3.0.6.ebuild
index 7ca9ea03f3db..515bd1b8416d 100644
--- a/sys-process/audit/audit-3.0.6.ebuild
+++ b/sys-process/audit/audit-3.0.6.ebuild
@@ -3,9 +3,9 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
-inherit autotools multilib multilib-minimal toolchain-funcs python-r1 linux-info systemd usr-ldscript
+inherit autotools multilib-minimal toolchain-funcs python-r1 linux-info systemd usr-ldscript
DESCRIPTION="Userspace utilities for storing and processing auditing records"
HOMEPAGE="https://people.redhat.com/sgrubb/audit/"
@@ -54,6 +54,7 @@ multilib_src_configure() {
--without-python
--without-python3
)
+
ECONF_SOURCE=${S} econf "${myeconfargs[@]}"
if multilib_is_native_abi && use python; then
@@ -148,7 +149,7 @@ pkg_postinst() {
lockdown_perms() {
# Upstream wants these to have restrictive perms.
# Should not || die as not all paths may exist.
- local basedir="$1"
+ local basedir="${1}"
chmod 0750 "${basedir}"/sbin/au{ditctl,ditd,report,search,trace} 2>/dev/null
chmod 0750 "${basedir}"/var/log/audit 2>/dev/null
chmod 0640 "${basedir}"/etc/audit/{auditd.conf,audit*.rules*} 2>/dev/null