summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-09-22 01:29:20 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-09-22 13:24:23 -0700
commit1db39caa60172f86d9f2c1d248e26c87f7ce5676 (patch)
tree52e1f37b8deafd28f7cccd3137c79f31a7dc2440 /sys-process/criu
parentsys-process/criu: add ~ppc64 keyword (diff)
downloadgentoo-1db39caa60172f86d9f2c1d248e26c87f7ce5676.tar.gz
gentoo-1db39caa60172f86d9f2c1d248e26c87f7ce5676.tar.bz2
gentoo-1db39caa60172f86d9f2c1d248e26c87f7ce5676.zip
sys-process/criu: revbump 3.14-r1, python no longer optional
python is no longer optional, criu target requires crit, which requires pycriu. also check for IA32 emulation only on amd64. and remove RAW_LDFLAGS, it was added by patch which is no longer applied to this version. LDFLAGS still not honored, #728148 Closes: https://bugs.gentoo.org/735636 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-process/criu')
-rw-r--r--sys-process/criu/criu-3.14-r2.ebuild (renamed from sys-process/criu/criu-3.14-r1.ebuild)28
1 files changed, 14 insertions, 14 deletions
diff --git a/sys-process/criu/criu-3.14-r1.ebuild b/sys-process/criu/criu-3.14-r2.ebuild
index 17298a55f2c3..0cab02a87743 100644
--- a/sys-process/criu/criu-3.14-r1.ebuild
+++ b/sys-process/criu/criu-3.14-r2.ebuild
@@ -14,16 +14,16 @@ SRC_URI="https://download.openvz.org/criu/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
-IUSE="doc python selinux setproctitle static-libs"
+IUSE="doc selinux setproctitle static-libs"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
+ ${PYTHON_DEPS}
dev-libs/protobuf-c
dev-libs/libnl:3
net-libs/libnet:1.1
sys-libs/libcap
- python? ( ${PYTHON_DEPS} )
selinux? ( sys-libs/libselinux )
setproctitle? ( dev-libs/libbsd )"
DEPEND="${RDEPEND}
@@ -32,14 +32,12 @@ DEPEND="${RDEPEND}
app-text/xmlto
)"
RDEPEND="${RDEPEND}
- python? (
- dev-python/protobuf-python[${PYTHON_USEDEP}]
- dev-python/ipaddr[${PYTHON_USEDEP}]
- )"
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/ipaddr[${PYTHON_USEDEP}]
+"
CONFIG_CHECK="~CHECKPOINT_RESTORE ~NAMESPACES ~PID_NS ~FHANDLE ~EVENTFD ~EPOLL ~INOTIFY_USER
- ~IA32_EMULATION ~UNIX_DIAG ~INET_DIAG ~INET_UDP_DIAG ~PACKET_DIAG ~NETLINK_DIAG ~TUN
- ~NETFILTER_XT_MARK"
+ ~UNIX_DIAG ~INET_DIAG ~INET_UDP_DIAG ~PACKET_DIAG ~NETLINK_DIAG ~TUN ~NETFILTER_XT_MARK"
# root access required for tests
RESTRICT="test"
@@ -60,6 +58,11 @@ criu_arch() {
esac
}
+pkg_setup() {
+ use amd64 && CONFIG_CHECK+=" ~IA32_EMULATION"
+ linux-info_pkg_setup
+}
+
src_prepare() {
default
@@ -81,7 +84,7 @@ src_configure() {
src_compile() {
local target="all $(usex doc 'docs' '')"
- RAW_LDFLAGS="$(raw-ldflags)" emake \
+ emake \
HOSTCC="$(tc-getBUILD_CC)" \
CC="$(tc-getCC)" \
LD="$(tc-getLD)" \
@@ -93,7 +96,6 @@ src_compile() {
ARCH="$(criu_arch)" \
V=1 WERROR=0 DEBUG=0 \
SETPROCTITLE=$(usex setproctitle) \
- PYCRIU=$(usex python) \
${target}
}
@@ -123,9 +125,7 @@ src_install() {
use doc && dodoc CREDITS README.md
- if use python ; then
- python_foreach_impl install_crit
- fi
+ python_foreach_impl install_crit
if ! use static-libs; then
find "${D}" -name "*.a" -delete || die