summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-06-24 13:36:08 -0400
committerAnthony G. Basile <blueness@gentoo.org>2018-06-24 13:36:26 -0400
commit8cb75eb073694925dbcc2c5c5846a880806a9951 (patch)
tree3eba28724b7edaa94368d321577a606ffd6bcd99 /sys-process/cronie
parentsys-kernel/kergen: Support python3.6 (diff)
downloadgentoo-8cb75eb073694925dbcc2c5c5846a880806a9951.tar.gz
gentoo-8cb75eb073694925dbcc2c5c5846a880806a9951.tar.bz2
gentoo-8cb75eb073694925dbcc2c5c5846a880806a9951.zip
sys-process/cronie: fix bug #658846
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sys-process/cronie')
-rw-r--r--sys-process/cronie/cronie-1.5.2.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/sys-process/cronie/cronie-1.5.2.ebuild b/sys-process/cronie/cronie-1.5.2.ebuild
index f9c9fbc31a16..04f7c7876b18 100644
--- a/sys-process/cronie/cronie-1.5.2.ebuild
+++ b/sys-process/cronie/cronie-1.5.2.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit autotools cron pam systemd user
+inherit autotools cron flag-o-matic pam systemd user
DESCRIPTION="Cronie is a standard UNIX daemon cron based on the original vixie-cron"
HOMEPAGE="https://github.com/cronie-crond/cronie"
@@ -14,7 +14,9 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~s
IUSE="+anacron +inotify pam selinux"
DEPEND="pam? ( virtual/pam )
- anacron? ( !sys-process/anacron )"
+ anacron? ( !sys-process/anacron
+ elibc_musl? ( sys-libs/obstack-standalone )
+ )"
RDEPEND="${DEPEND}
sys-apps/debianutils"
@@ -46,6 +48,10 @@ src_configure() {
--with-daemon_username=cron
--with-daemon_groupname=cron
)
+
+ if use anacron; then
+ use elibc_musl && append-cflags "-lobstack"
+ fi
SPOOL_DIR="/var/spool/cron/crontabs" \
ANACRON_SPOOL_DIR="/var/spool/anacron" \
econf "${myeconfargs[@]}"