summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-08-27 13:47:08 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-08-27 13:48:14 +0200
commitf8e2351e2fc6d869593ce5f1775526ec399270bf (patch)
tree9427a904f13e303ff045d09342f67b672d4c71ee /sys-process/htop
parentdev-perl/Bio-DB-HTS: remove old (diff)
downloadgentoo-f8e2351e2fc6d869593ce5f1775526ec399270bf.tar.gz
gentoo-f8e2351e2fc6d869593ce5f1775526ec399270bf.tar.bz2
gentoo-f8e2351e2fc6d869593ce5f1775526ec399270bf.zip
sys-process/htop: bump to v3.0.0
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-process/htop')
-rw-r--r--sys-process/htop/Manifest1
-rw-r--r--sys-process/htop/htop-3.0.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/sys-process/htop/Manifest b/sys-process/htop/Manifest
index 47f15a7d70f8..9498c38b03fe 100644
--- a/sys-process/htop/Manifest
+++ b/sys-process/htop/Manifest
@@ -1,2 +1,3 @@
DIST htop-2.2.0.tar.gz 308109 BLAKE2B 323a3bfe5032b6d59a3f751831a2af6aa7ae7e9ecceb35828812cb375d919de51f401ffe59fffdfc83a72c8dace879c5d5a0e857511c20e2126d11cdc4101b0b SHA512 ec1335bf0e3e0387e5e50acbc508d0effad19c4bc1ac312419dc97b82901f4819600d6f87a91668f39d429536d17304d4b14634426a06bec2ecd09df24adc62e
+DIST htop-3.0.0.tar.gz 179371 BLAKE2B 7501d8277eb97e39f7a8e2e9191bdde97deca6f3240a3e497ce55e71b0659122223356d4ff03086f9303b82ea4de0fa4e7909baca6de063ac6b22d7b6530f9be SHA512 36dc37b416b9917005007448fe73fdd6475a3f7f8442a083923d3f5dfb706d0f1731255522a99b67cc547b239acb1c68b144f8d600e243eeba160b2a43e8339a
DIST htop-3.0.0_beta5.tar.gz 175780 BLAKE2B f7d03485e74387c656e5a576f0a53c832bac668cee79750402335b2051a17d405392b99316f1546cc76fa83dc3bc85055ca58b928225df0e162ffdb9c1889a5f SHA512 eaa04a278257a1447cd60825083c864d3c23a4a5607447ce05356d550f42ff68a810f14bf91314b7266f9741aab8141d67d98316a31fa7806fb6b858cc804344
diff --git a/sys-process/htop/htop-3.0.0.ebuild b/sys-process/htop/htop-3.0.0.ebuild
new file mode 100644
index 000000000000..eacb7a88db21
--- /dev/null
+++ b/sys-process/htop/htop-3.0.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit autotools linux-info python-any-r1
+
+DESCRIPTION="interactive process viewer"
+HOMEPAGE="https://htop.dev/ https://github.com/htop-dev/htop"
+SRC_URI="https://github.com/htop-dev/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+IUSE="kernel_FreeBSD kernel_linux openvz unicode vserver"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="sys-libs/ncurses:0=[unicode?]"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}"
+
+DOCS=( ChangeLog README )
+
+CONFIG_CHECK="~TASKSTATS ~TASK_XACCT ~TASK_IO_ACCOUNTING ~CGROUPS"
+
+PATCHES=()
+
+pkg_setup() {
+ if ! has_version sys-process/lsof; then
+ ewarn "To use lsof features in htop (what processes are accessing"
+ ewarn "what files), you must have sys-process/lsof installed."
+ fi
+
+ python-any-r1_pkg_setup
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ [[ $CBUILD != $CHOST ]] && export ac_cv_file__proc_{meminfo,stat}=yes #328971
+
+ local myeconfargs=(
+ # fails to build against recent hwloc versions
+ --disable-hwloc
+ --enable-taskstats
+ $(use_enable kernel_linux cgroup)
+ $(use_enable kernel_linux linux-affinity)
+ $(use_enable openvz)
+ $(use_enable unicode)
+ $(use_enable vserver)
+ )
+ econf ${myeconfargs[@]}
+}