summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNelo-T. Wallus <nelo@wallus.de>2017-08-01 21:44:13 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-08-02 09:43:29 +0200
commit2752abb987ff28997e5f7fd2da3adb5a4d6db28c (patch)
treec52335be3d6ca46fd6e4826fe06ae14d51dd2564 /sys-process/nmon/nmon-16g.ebuild
parentdev-vcs/git: Removed old. (diff)
downloadgentoo-2752abb987ff28997e5f7fd2da3adb5a4d6db28c.tar.gz
gentoo-2752abb987ff28997e5f7fd2da3adb5a4d6db28c.tar.bz2
gentoo-2752abb987ff28997e5f7fd2da3adb5a4d6db28c.zip
sys-process/nmon: Bump version
Package-Manager: Portage-2.3.6, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/5269
Diffstat (limited to 'sys-process/nmon/nmon-16g.ebuild')
-rw-r--r--sys-process/nmon/nmon-16g.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sys-process/nmon/nmon-16g.ebuild b/sys-process/nmon/nmon-16g.ebuild
new file mode 100644
index 000000000000..918ae4569cc1
--- /dev/null
+++ b/sys-process/nmon/nmon-16g.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+MY_P="lmon${PV}"
+
+DESCRIPTION="Nigel's performance MONitor for CPU, memory, network, disks, etc..."
+HOMEPAGE="http://nmon.sourceforge.net/"
+LICENSE="GPL-3"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.c"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp -v -f "${DISTDIR}"/${MY_P}.c "${S}"/${PN}.c || die
+}
+
+src_configure() {
+ local cflags=(
+ ## recommended by upstream to be always on
+ -DGETUSER
+ -DJFS
+ -DLARGEMEM
+ -DKERNEL_2_6_18
+
+ ## archs
+ $(usex amd64 -DX86 '')
+ $(usex x86 -DX86 '')
+ $(usex arm -DARM '')
+ $(usex ppc64 -DPOWER '')
+ )
+ append-cflags "${cflags[@]}"
+ export LDLIBS="$( $(tc-getPKG_CONFIG) --libs ncurses ) -lm"
+}
+
+src_compile() {
+ emake ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+}