summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-02-09 16:05:10 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-02-09 16:05:38 +0100
commit78e925e65dc860c6c7f315b68e983c0a9af4283c (patch)
treef9223a637597025e7b17079bc573c37fa16c7474 /sys-process/numactl
parentsys-process/numactl: Removed old. (diff)
downloadgentoo-78e925e65dc860c6c7f315b68e983c0a9af4283c.tar.gz
gentoo-78e925e65dc860c6c7f315b68e983c0a9af4283c.tar.bz2
gentoo-78e925e65dc860c6c7f315b68e983c0a9af4283c.zip
sys-process/numactl: Added live ebuild.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-process/numactl')
-rw-r--r--sys-process/numactl/numactl-9999.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/sys-process/numactl/numactl-9999.ebuild b/sys-process/numactl/numactl-9999.ebuild
new file mode 100644
index 000000000000..567cee9892f0
--- /dev/null
+++ b/sys-process/numactl/numactl-9999.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools toolchain-funcs multilib-minimal
+
+DESCRIPTION="Utilities and libraries for NUMA systems"
+HOMEPAGE="https://github.com/numactl/numactl"
+if [[ "${PV}" = 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/numactl/numactl.git"
+else
+ SRC_URI="ftp://oss.sgi.com/www/projects/libnuma/download/${P}.tar.gz"
+ # ARM lacks the __NR_migrate_pages syscall.
+ KEYWORDS="~amd64 -arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="static-libs"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.8-cpuid-pic.patch #456238
+ "${FILESDIR}"/${PN}-2.0.10-numademo-cflags.patch #540856
+ "${FILESDIR}"/${PN}-2.0.11-sysmacros.patch #580098
+)
+
+src_prepare() {
+ default
+ eautoreconf
+ # We need to copy the sources or else tests will fail
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_compile() {
+ multilib_is_native_abi && default || emake libnuma.la
+}
+
+multilib_src_test() {
+ if multilib_is_native_abi ; then
+ if [ -d /sys/devices/system/node ]; then
+ einfo "The only generically safe test is regress2."
+ einfo "The other test cases require 2 NUMA nodes."
+ emake regress2
+ else
+ ewarn "You do not have baseline NUMA support in your kernel, skipping tests."
+ fi
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" \
+ install$(multilib_is_native_abi || echo "-libLTLIBRARIES install-includeHEADERS")
+ find "${ED%/}"/usr/ -name libnuma.la -delete || die
+}
+
+multilib_src_install_all() {
+ local DOCS=( README TODO CHANGES DESIGN )
+ einstalldocs
+ # delete man pages provided by the man-pages package #238805
+ rm -r "${ED%/}"/usr/share/man/man[25] || die
+}