summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-08-24 09:47:43 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-08-24 09:47:57 +0200
commitc13de7ca417bd2105565717e7648470cf4fffab2 (patch)
tree894be144b9ac97d94b7fbbf3eb9c612fa17225e5 /sys-process/parallel/parallel-20160822.ebuild
parentdev-tcltk/tcl3d: Correct path typo, fixes #563400 (diff)
downloadgentoo-c13de7ca417bd2105565717e7648470cf4fffab2.tar.gz
gentoo-c13de7ca417bd2105565717e7648470cf4fffab2.tar.bz2
gentoo-c13de7ca417bd2105565717e7648470cf4fffab2.zip
sys-process/parallel: Bump to version 20160822
Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-process/parallel/parallel-20160822.ebuild')
-rw-r--r--sys-process/parallel/parallel-20160822.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-process/parallel/parallel-20160822.ebuild b/sys-process/parallel/parallel-20160822.ebuild
new file mode 100644
index 000000000000..74ef0d90fca1
--- /dev/null
+++ b/sys-process/parallel/parallel-20160822.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A shell tool for executing jobs in parallel locally or on remote machines"
+HOMEPAGE="https://www.gnu.org/software/parallel/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-lang/perl:=
+ dev-perl/Devel-Size
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Temp
+ virtual/perl-IO"
+# moreutils for `parallel` and grass for 'sql.1' manpage
+DEPEND="${RDEPEND}
+ !<sys-apps/moreutils-0.45-r1
+ !<sci-geosciences/grass-6.4.1-r1"
+
+DOCS="NEWS README"
+
+src_configure() {
+ econf --docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+
+ # See src/Makefile.am for this one:
+ rm -f "${ED}"usr/bin/sem
+ dosym ${PN} /usr/bin/sem
+}
+
+pkg_postinst() {
+ elog "To distribute jobs to remote machines you'll need these dependencies"
+ elog " net-misc/openssh"
+ elog " net-misc/rsync"
+}