summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-22 22:41:15 +0100
committerSam James <sam@gentoo.org>2021-07-22 22:52:04 +0100
commit54116e607d2213fe484af4c90f03edbc1b8a4df1 (patch)
tree886e9a2be2a523b3cc269dbba00025d2c4bf31f2 /sys-process/parallel
parentapp-misc/pax-utils: bump up to 1.3.3 (glibc-2.34 compatible) (diff)
downloadgentoo-54116e607d2213fe484af4c90f03edbc1b8a4df1.tar.gz
gentoo-54116e607d2213fe484af4c90f03edbc1b8a4df1.tar.bz2
gentoo-54116e607d2213fe484af4c90f03edbc1b8a4df1.zip
sys-process/parallel: add 20210722
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process/parallel')
-rw-r--r--sys-process/parallel/Manifest2
-rw-r--r--sys-process/parallel/parallel-20210722.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/sys-process/parallel/Manifest b/sys-process/parallel/Manifest
index 285290351834..5d88350d2612 100644
--- a/sys-process/parallel/Manifest
+++ b/sys-process/parallel/Manifest
@@ -4,3 +4,5 @@ DIST parallel-20210522.tar.bz2 2246330 BLAKE2B cf3dc65526522cedb22b85fabd364dc89
DIST parallel-20210522.tar.bz2.sig 2080 BLAKE2B 8053520c93ee1dae0d158adb6d6867efda6496b2874578e70b640673dba5813898ba4fad2156f3f00a7f87ef551c41ecc8d4d61e0573752abe505d4eea6c2a86 SHA512 536309731b87ac6a523dda91d23b88b60aca7f4516a5dbba9efe08085f9a7590c7e797bd3a39afd52fdccfe1f3a776f1df66751817943f06adc17695bf14f1e2
DIST parallel-20210622.tar.bz2 2251075 BLAKE2B 4855ee0e581bf1d3ebb7dd16e4126873f0bf4294ebfc8260ec75901b3a80126a2a7c4d11c1a997557cf37e8077be24b9f1a1e97e92629347f1a55e23e8fbd9df SHA512 084537fb2b86f284f8b09dd506a79e07856612a1bb03914deec6baefd08df4c9878ad0247a527b4bc5a6d42e1a9a11d13a4a6e304ea1c3c8083b5faaf7530937
DIST parallel-20210622.tar.bz2.sig 2080 BLAKE2B f21c6dc3b90757e56547b88ea429e33cb04b7853cc3493a19bd3352a9e2c14f8d293ee1180cacd1449a37047e3084fa4d12dccc5767a28e2daf40d086c9f5404 SHA512 50fa1de3b40f8447c9adf5e52c23e8cf932dca0565ac663bab128f44db5e8159a399208d1a23ed6d5eff78b9cb0d6eb4ada92d642279e41d40b0c429ef4c825e
+DIST parallel-20210722.tar.bz2 2248893 BLAKE2B c72da41de516e00af9d73216a134a184b3436f4d8be89c92bf4607243ba18c6530364cd7b3b4b99cba8f7a55c8a0235819edd1dbe431de1b37716fe104cd9f72 SHA512 2b5bec76ca6db090bc93f57bd09771d264a761677adbd6f4b93256776cf65a62a5a3a4641c450b68044cb7e86c5e7202d9455d2f9b0ad0cb8ad64d6da6955f89
+DIST parallel-20210722.tar.bz2.sig 2080 BLAKE2B 48186854bb752e50c719f2fc6c964b3dd0b3407bf5d0683dafb475a7e6a537de1ae0e6f054f9105a4860b2fcfab50bc59ca159639bf72fcc42373f457af1cb93 SHA512 bc999d37c6eed6b170b845a01d3b0fb88661ed271fe4c18609144d3d224173ac2c66bd6fe40a5b8ddc4894503a38e558835a45ffad3ee8c0201d04dc1aed9a3c
diff --git a/sys-process/parallel/parallel-20210722.ebuild b/sys-process/parallel/parallel-20210722.ebuild
new file mode 100644
index 000000000000..df4e4dc4a9df
--- /dev/null
+++ b/sys-process/parallel/parallel-20210722.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/oletange.asc
+inherit verify-sig
+
+DESCRIPTION="A shell tool for executing jobs in parallel locally or on remote machines"
+HOMEPAGE="https://www.gnu.org/software/parallel/ https://git.savannah.gnu.org/cgit/parallel.git/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+SRC_URI+=" verify-sig? ( mirror://gnu/${PN}/${P}.tar.bz2.sig )"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="dev-lang/perl:=
+ dev-perl/Devel-Size
+ dev-perl/Text-CSV
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Temp
+ virtual/perl-IO"
+DEPEND="${RDEPEND}"
+BDEPEND="verify-sig? ( >=app-crypt/openpgp-keys-oletange-20210423 )"
+
+src_configure() {
+ econf --docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+}