summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-08-14 17:22:48 -0600
committerTim Harder <radhermit@gentoo.org>2019-08-14 17:24:04 -0600
commit3e40f0e05b2d496aa6ac21f9a84f331b82d8f095 (patch)
tree44d2a30fa44da2701edae8b2a19e801a199541af /sys-process/procenv/procenv-0.51.ebuild
parentprofiles/package.mask: update dev-java/itext mask (diff)
downloadgentoo-3e40f0e05b2d496aa6ac21f9a84f331b82d8f095.tar.gz
gentoo-3e40f0e05b2d496aa6ac21f9a84f331b82d8f095.tar.bz2
gentoo-3e40f0e05b2d496aa6ac21f9a84f331b82d8f095.zip
sys-process/procenv: version bump to 0.51
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'sys-process/procenv/procenv-0.51.ebuild')
-rw-r--r--sys-process/procenv/procenv-0.51.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-process/procenv/procenv-0.51.ebuild b/sys-process/procenv/procenv-0.51.ebuild
new file mode 100644
index 000000000000..2f1408191151
--- /dev/null
+++ b/sys-process/procenv/procenv-0.51.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="command-line utility to show process environment"
+HOMEPAGE="https://github.com/jamesodhunt/procenv"
+SRC_URI="https://github.com/jamesodhunt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-libs/check )"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}"/${PN}-0.45-flags.patch
+ )
+
+ default
+ eautoreconf
+}