summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Linden <karl.j.linden@gmail.com>2018-10-13 17:32:42 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-24 13:56:25 +0200
commit2cfc06b5af03ba8fc3369dfa013cdf7e60cbcb76 (patch)
tree21fb0b90948b1028363bb354c763511e4426b46b /sys-process/rtirq/rtirq-20180209.ebuild
parentsys-process/rtirq: correct HOMEPAGE and SRC_URI (diff)
downloadgentoo-2cfc06b5af03ba8fc3369dfa013cdf7e60cbcb76.tar.gz
gentoo-2cfc06b5af03ba8fc3369dfa013cdf7e60cbcb76.tar.bz2
gentoo-2cfc06b5af03ba8fc3369dfa013cdf7e60cbcb76.zip
sys-process/rtirq: version bump to 20180209
- Install systemd service file. - Bump to EAPI 7. - Drop explicit RDEPEND on sys-apps/util-linux. - Group variables as in skel.ebuild. - Update LICENSE to GPL-2+ in accordance with rtirq.sh. - Do not use PN variable in src_install. - Remove OpenRC specific code that was not very useful anyway. - Use KV_LOCAL from linux-info to detect if the current kernel is realtime or not. - Avoid using grep unnecessarily. Closes: https://bugs.gentoo.org/653732 Signed-off-by: Karl Linden <karl.j.linden@gmail.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10135 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-process/rtirq/rtirq-20180209.ebuild')
-rw-r--r--sys-process/rtirq/rtirq-20180209.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-process/rtirq/rtirq-20180209.ebuild b/sys-process/rtirq/rtirq-20180209.ebuild
new file mode 100644
index 000000000000..5186ad22dd47
--- /dev/null
+++ b/sys-process/rtirq/rtirq-20180209.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit linux-info systemd
+
+DESCRIPTION="Modify realtime scheduling policy and priority of IRQ handlers"
+HOMEPAGE="http://www.rncbc.org/archive/#rtirq"
+SRC_URI="http://www.rncbc.org/archive/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ get_version
+
+ # Correct config file path.
+ sed -i -e "s:^\(RTIRQ_CONFIG\=\)\(.*\):\1/etc/conf.d/rtirq:" ${PN}.sh || die
+ sed -i -e "s:/etc/sysconfig/rtirq:/etc/conf.d/rtirq:" ${PN}.conf || die
+
+ default
+}
+
+src_install() {
+ dosbin rtirq.sh
+ doinitd "${FILESDIR}"/rtirq
+ newconfd rtirq.conf rtirq
+ systemd_dounit rtirq.service
+}
+
+pkg_postinst() {
+ if [[ ${KV_LOCAL} != *rt* ]] ; then
+ elog "To use rtirq you need a realtime kernel."
+ elog "Realtime kernel sources are supplied in sys-kernel/rt-sources."
+ fi
+}