summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-07-07 14:32:29 -0500
committerAustin English <wizardedit@gentoo.org>2016-07-07 14:47:00 -0500
commit79a83cb45f9b5616974456a0fa2573c6ad116826 (patch)
tree6a21e7fc46324d2d389dc947c4bcc409d5bab413 /sys-process/wait_on_pid/wait_on_pid-0.0.2-r1.ebuild
parentsys-process/nmon: add maintainer-needed (diff)
downloadgentoo-79a83cb45f9b5616974456a0fa2573c6ad116826.tar.gz
gentoo-79a83cb45f9b5616974456a0fa2573c6ad116826.tar.bz2
gentoo-79a83cb45f9b5616974456a0fa2573c6ad116826.zip
sys-process/wait_on_pid: bump to EAPI 6, add maintainer-needed
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-process/wait_on_pid/wait_on_pid-0.0.2-r1.ebuild')
-rw-r--r--sys-process/wait_on_pid/wait_on_pid-0.0.2-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-process/wait_on_pid/wait_on_pid-0.0.2-r1.ebuild b/sys-process/wait_on_pid/wait_on_pid-0.0.2-r1.ebuild
new file mode 100644
index 000000000000..1baae42c3a56
--- /dev/null
+++ b/sys-process/wait_on_pid/wait_on_pid-0.0.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+DESCRIPTION="small utility to wait for an arbitrary process to exit"
+HOMEPAGE="https://dev.gentoo.org/~zzam/wait_on_pid/"
+SRC_URI="mirror://gentoo/$P.tar.bz2 https://dev.gentoo.org/~zzam/wait_on_pid/$P.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+src_install() {
+ default
+ dobin wait_on_pid
+}