summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-07-26 16:51:24 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-07-26 17:37:45 +0200
commit16b91fc914799e45f963a99177bd1d7cfa50058a (patch)
tree2362901630c31b0958ac90371452b1542488cf74 /sys-process
parentwww-client/opera: Switch to HTTPS. (diff)
downloadgentoo-16b91fc914799e45f963a99177bd1d7cfa50058a.tar.gz
gentoo-16b91fc914799e45f963a99177bd1d7cfa50058a.tar.bz2
gentoo-16b91fc914799e45f963a99177bd1d7cfa50058a.zip
sys-process/prll: version bump.
Also introduce the use of the readme.gentoo-r1 eclass to produce a nicely formatted README file. Closes: https://bugs.gentoo.org/662046 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/prll/Manifest1
-rw-r--r--sys-process/prll/prll-0.6.4.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-process/prll/Manifest b/sys-process/prll/Manifest
index f5cdfca57a74..5d3332842565 100644
--- a/sys-process/prll/Manifest
+++ b/sys-process/prll/Manifest
@@ -1 +1,2 @@
DIST prll-0.6.2.tar.bz2 37870 BLAKE2B 00adcb56e49dfe6a04235f628fee1aee5a0164ada30e3a2ac624f73f7e613c7bdd411012f01e8278bc95a1e8e96479d9177f48745759feb4681c0f75a6420419 SHA512 6157ab4d69ab21b0995d5e8e788605b9b602fa0268beae2d6b69e6bf32c734869f023d881ecdd0df83c1f45b584c88eef8beb88d2c58f657340697bf48dfd8cd
+DIST prll-0.6.4.tar.gz 49885 BLAKE2B 07a63ddc6260c302070f27488142118286a0312ef807a6eaebbac180dbfb479c78f66cfb96cddbb7a62c3d96a79a9c4962daf1fbd308ec475ae8d03a999fd276 SHA512 df830eae9be91e175444ba14c23efde3f10152b968ca6b1365e0ab57c68df1a00712a0e6d77cd02aae4ed7a23fc7c25f207ba08bc1559b8331c42dec1d38dbfa
diff --git a/sys-process/prll/prll-0.6.4.ebuild b/sys-process/prll/prll-0.6.4.ebuild
new file mode 100644
index 000000000000..1d9cfb0e7449
--- /dev/null
+++ b/sys-process/prll/prll-0.6.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs readme.gentoo-r1
+
+DESCRIPTION="A utility for parallelizing execution of shell functions"
+HOMEPAGE="https://github.com/exzombie/prll"
+SRC_URI="https://github.com/exzombie/prll/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+RESTRICT="test"
+
+DOC_CONTENTS="
+You must source the prll.sh file located\nin /etc/profile.d to be able to use prll:\n
+ $ source /etc/profile.d/prll.sh
+"
+
+src_prepare() {
+ default
+ sed \
+ -e '/then sh/d' \
+ -e '/then zsh/d' \
+ -e '/then dash/d' \
+ -i tests/Makefile || die
+ tc-export CC
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" install
+ einstalldocs
+ readme.gentoo_create_doc
+ rm -rf "${D}/usr/share/doc/prll" || die
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}