summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Schollmeyer <nex+b-g-o@nexadn.de>2022-09-14 22:31:05 +0200
committerSam James <sam@gentoo.org>2022-09-15 13:48:23 +0100
commit34ccc1d848c74a17edebc48f0c0c936106ffa278 (patch)
tree62b9aaaea7a52146705d3d12c5ac6569bbb67013 /sys-process
parentsys-apps/file: add zstd support to live (diff)
downloadgentoo-34ccc1d848c74a17edebc48f0c0c936106ffa278.tar.gz
gentoo-34ccc1d848c74a17edebc48f0c0c936106ffa278.tar.bz2
gentoo-34ccc1d848c74a17edebc48f0c0c936106ffa278.zip
sys-process/btop: Hard-depend on sys-devel/gcc
Clang currently does not have support for the C++ 20 ranges library, causing build failures wis sys-process/btop. The only compiler supported upstream is sys-devel/gcc [0]. This commit enforces g++ to be used as a compiler until proper clang support is available. [0] https://github.com/aristocratos/btop/issues/324 Closes: https://bugs.gentoo.org/839318 Signed-off-by: Adrian Schollmeyer <nex+b-g-o@nexadn.de> Closes: https://github.com/gentoo/gentoo/pull/27255 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/btop/btop-1.2.8.ebuild13
-rw-r--r--sys-process/btop/btop-1.2.9.ebuild13
2 files changed, 26 insertions, 0 deletions
diff --git a/sys-process/btop/btop-1.2.8.ebuild b/sys-process/btop/btop-1.2.8.ebuild
index b4ac52c9fecc..ee0bbdefbd6d 100644
--- a/sys-process/btop/btop-1.2.8.ebuild
+++ b/sys-process/btop/btop-1.2.8.ebuild
@@ -13,6 +13,19 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 arm64 ppc64 ~riscv x86"
+BDEPEND="
+ >=sys-devel/gcc-8
+"
+
+pkg_setup() {
+ if [[ "${MERGE_TYPE}" != "binary" ]]; then
+ if ! tc-is-gcc ; then
+ # https://bugs.gentoo.org/839318
+ die "$(tc-getCXX) is not a supported compiler. Please use sys-devel/gcc instead."
+ fi
+ fi
+}
+
src_prepare() {
default
# btop installs README.md to /usr/share/btop by default
diff --git a/sys-process/btop/btop-1.2.9.ebuild b/sys-process/btop/btop-1.2.9.ebuild
index 53e5416f327e..6bf13cbd7d95 100644
--- a/sys-process/btop/btop-1.2.9.ebuild
+++ b/sys-process/btop/btop-1.2.9.ebuild
@@ -13,6 +13,19 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+BDEPEND="
+ >=sys-devel/gcc-8
+"
+
+pkg_setup() {
+ if [[ "${MERGE_TYPE}" != "binary" ]]; then
+ if ! tc-is-gcc ; then
+ # https://bugs.gentoo.org/839318
+ die "$(tc-getCXX) is not a supported compiler. Please use sys-devel/gcc instead."
+ fi
+ fi
+}
+
src_prepare() {
default
# btop installs README.md to /usr/share/btop by default