summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Schollmeyer <nex+b-g-o@nexadn.de>2022-08-28 19:34:46 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-09-07 08:30:50 +0200
commit872cadf4310a29157ae45a70753f667b8453e9a1 (patch)
tree835050e5345da0443620aed20a2b0d9cc9ff277e /sys-process
parentsys-process/btop: drop 1.2.7-r1 (diff)
downloadgentoo-872cadf4310a29157ae45a70753f667b8453e9a1.tar.gz
gentoo-872cadf4310a29157ae45a70753f667b8453e9a1.tar.bz2
gentoo-872cadf4310a29157ae45a70753f667b8453e9a1.zip
sys-process/btop: add 1.2.9
Signed-off-by: Adrian Schollmeyer <nex+b-g-o@nexadn.de> Closes: https://github.com/gentoo/gentoo/pull/27045 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/btop/Manifest1
-rw-r--r--sys-process/btop/btop-1.2.9.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-process/btop/Manifest b/sys-process/btop/Manifest
index cdca0835ddce..3914b0eb65a9 100644
--- a/sys-process/btop/Manifest
+++ b/sys-process/btop/Manifest
@@ -1 +1,2 @@
DIST btop-1.2.8.tar.gz 976370 BLAKE2B ab71ac322afd84b5b73c5deb9003f319078809d81e2725a7447d2a8fe7539af21c669e7199a3422b2a1cc2ecbd79a46179343e00311f2d56bfa30f51d6340bd3 SHA512 4b5a3685ca5cf301cd7d6556bd365892587e6811f8323ca66728022aba7cc3ff95cf591b452151c9431824dc458bc3d09e10474c7c02a944e8931c4585914f5a
+DIST btop-1.2.9.tar.gz 978265 BLAKE2B ff80079a393342a2cf3aefad6ead8be8b786fbc2b9445e8e2a8b37386f65f4060c801a6f59d216cd611783f4135a60d64b95ff2b5e1a3d62bb2d40030bde8974 SHA512 424573c8f82d0daf748cba7c82e72232773f145af9792ac78a5f5f18d98a8695f11452de106c72cf685ecb8cc89729471a494f9ea6b4300bdb2fa6acdbf4ac60
diff --git a/sys-process/btop/btop-1.2.9.ebuild b/sys-process/btop/btop-1.2.9.ebuild
new file mode 100644
index 000000000000..53e5416f327e
--- /dev/null
+++ b/sys-process/btop/btop-1.2.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs xdg-utils
+
+DESCRIPTION="A monitor of resources"
+HOMEPAGE="https://github.com/aristocratos/btop"
+SRC_URI="https://github.com/aristocratos/btop/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+src_prepare() {
+ default
+ # btop installs README.md to /usr/share/btop by default
+ sed -i '/^.*cp -p README.md.*$/d' Makefile || die
+}
+
+src_compile() {
+ # Disable btop optimization flags, since we have our flags in CXXFLAGS
+ emake OPTFLAGS="" CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ emake \
+ PREFIX="${EPREFIX}/usr" \
+ DESTDIR="${D}" \
+ install
+
+ dodoc README.md CHANGELOG.md
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}