summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-01-01 22:23:44 -0500
committerAnthony G. Basile <blueness@gentoo.org>2016-01-01 22:23:44 -0500
commitcb3636879e1fe4fec5c92fd166a3ab2b43fe3d1e (patch)
tree0c1f8d31cd300d2055e6afc4385d1cc10bcda398 /sys-process
parentsys-process/fcron: fix minor typo (diff)
downloadgentoo-cb3636879e1fe4fec5c92fd166a3ab2b43fe3d1e.tar.gz
gentoo-cb3636879e1fe4fec5c92fd166a3ab2b43fe3d1e.tar.bz2
gentoo-cb3636879e1fe4fec5c92fd166a3ab2b43fe3d1e.zip
sys-process/fcron: version bump to 3.2.0
Package-Manager: portage-2.2.24
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/fcron/Manifest1
-rw-r--r--sys-process/fcron/fcron-3.2.0.ebuild211
2 files changed, 212 insertions, 0 deletions
diff --git a/sys-process/fcron/Manifest b/sys-process/fcron/Manifest
index ece19da98518..8f3512ad19e8 100644
--- a/sys-process/fcron/Manifest
+++ b/sys-process/fcron/Manifest
@@ -1,2 +1,3 @@
DIST fcron-3.1.1.src.tar.gz 597094 SHA256 449e21f09f80bd419d87165ba15dad94ad8ab215b7946fcf805b5340f019e952 SHA512 ce20f0aee72521f809af2be13ba797e0f6ac65f12f7797e67a4db56c3b111d24c499c135ec1c948d8385ded415da25a258daf90051a75f603f7322c23dbca945 WHIRLPOOL e3f4d056dd9926629c7ea36de2d5d768f510f256c6cdf0b051baaf5fda776d6295dd8a3213c32765d871cd6bdfc8bbb0bc7b5b0ab1da42c78441e19458594abe
DIST fcron-3.1.2.src.tar.gz 592409 SHA256 1c9299baab86e2b141031193c98ccd2e1b52d97a023b45a9e80266372ab11a5d SHA512 14aec35031449bb8abb81bee781215a09a6cd1d8e08a002ca391ea84c05b9c1cd07ef383e4fc3ee4ae928b60ad75f3f91114a41336110283a07fab64dc770503 WHIRLPOOL 0ec40e9921c187d87247a2bd5b0f807dda6a780e313608ba5c0933d1c470313b9db7f6d5b0ff15b7a853e966bb738c4bbac1c80a54541f402c2c51044f53cca9
+DIST fcron-3.2.0.src.tar.gz 595408 SHA256 eb13b86ed96805d117e19847f1da30b834f1990f7ef4c38f5007234d44679564 SHA512 97b200dfec02ca0aba76abf3cf71f54608fbadf46aa29d81d7316920fb1bebbba81d0118925f658cd9062f362b6075467c7f595e736b47616995a95958ae776b WHIRLPOOL 58cd9e7484181354518a53b99a2465608ba94001cf5908342b0e195b7436c0296b6a60a428f6d4136c65ce02644fa568e3a706962d76f6e59fcbe948b4bf0afc
diff --git a/sys-process/fcron/fcron-3.2.0.ebuild b/sys-process/fcron/fcron-3.2.0.ebuild
new file mode 100644
index 000000000000..117234e54099
--- /dev/null
+++ b/sys-process/fcron/fcron-3.2.0.ebuild
@@ -0,0 +1,211 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+WANT_AUTOMAKE=none
+
+inherit cron pam eutils flag-o-matic user autotools systemd
+
+MY_P=${P/_/-}
+DESCRIPTION="A command scheduler with extended capabilities over cron and anacron"
+HOMEPAGE="http://fcron.free.fr/"
+SRC_URI="http://fcron.free.fr/archives/${MY_P}.src.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug pam selinux linguas_fr +mta +system-crontab readline"
+
+DEPEND="selinux? ( sys-libs/libselinux )
+ mta? ( virtual/mta )
+ pam? ( virtual/pam )
+ readline? ( sys-libs/readline:= )"
+
+# see bug 282214 for the reason to depend on bash
+RDEPEND="${DEPEND}
+ app-shells/bash
+ app-misc/editor-wrapper
+ pam? ( sys-auth/pambase )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup fcron
+ enewuser fcron -1 -1 -1 fcron
+ rootuser=$(egetent passwd 0 | cut -d ':' -f 1)
+ [[ ${rootuser} ]] || rootuser=root
+ rootgroup=$(egetent group 0 | cut -d ':' -f 1)
+ [[ ${rootgroup} ]] || rootgroup=root
+}
+
+src_prepare() {
+ # respect LDFLAGS
+ sed -i "s:\(@LIBS@\):\$(LDFLAGS) \1:" Makefile.in || die "sed failed"
+
+ sed -i -e 's:/etc/fcrontab:/etc/fcron/fcrontab:' script/check_system_crontabs.sh || die
+
+ epatch "${FILESDIR}"/${PN}-3.1.1-noreadline.patch
+ eautoconf
+}
+
+src_configure() {
+ local myconf
+
+ # Don't try to pass --with-debug as it'll play with cflags as
+ # well, and run foreground which is a _very_ nasty idea for
+ # Gentoo.
+ use debug && append-flags -DDEBUG
+
+ # bindir is used just for calling fcronsighup
+ econf \
+ --with-cflags="${CFLAGS}" \
+ --bindir=/usr/libexec \
+ --sbindir=/usr/libexec \
+ $(use_with pam) \
+ $(use_with mta sendmail) \
+ $(use_with selinux) \
+ $(use_with readline) \
+ --without-audit \
+ --sysconfdir=/etc/fcron \
+ --with-username=fcron \
+ --with-groupname=fcron \
+ --with-piddir=/var/run \
+ --with-spooldir=/var/spool/fcron \
+ --with-fifodir=/var/run \
+ --with-fcrondyn=yes \
+ --disable-checks \
+ --with-editor=/usr/libexec/editor \
+ --with-shell=/bin/sh \
+ --without-db2man --without-dsssl-dir \
+ --with-rootname=${rootuser} \
+ --with-rootgroup=${rootgroup} \
+ $(systemd_with_unitdir)
+}
+
+src_compile() {
+ default
+
+ # bug #216460
+ sed -i \
+ -e 's:/usr/local/etc/fcron:/etc/fcron/fcron:g' \
+ -e 's:/usr/local/etc:/etc:g' \
+ -e 's:/usr/local/:/usr/:g' \
+ doc/*/*/*.{txt,1,5,8,html} \
+ || die "unable to fix documentation references"
+}
+
+src_install() {
+ keepdir /var/spool/fcron
+
+ exeinto /usr/libexec
+ doexe fcron fcronsighup
+
+ dobin fcrondyn fcrontab
+
+ insinto /etc/fcron
+ doins files/fcron.{allow,deny,conf}
+
+ if use system-crontab; then
+ dosym fcrontab /usr/bin/crontab
+
+ exeinto /usr/libexec
+ newexe script/check_system_crontabs.sh check_system_crontabs
+
+ insinto /etc/fcron
+ newins "${FILESDIR}"/fcrontab.2 fcrontab
+
+ fowners ${rootuser}:fcron /etc/fcron/fcrontab
+ fperms 0640 /etc/fcron/fcrontab
+
+ insinto /etc
+ doins "${FILESDIR}"/crontab
+ fi
+
+ fowners fcron:fcron \
+ /var/spool/fcron \
+ /usr/bin/fcron{dyn,tab}
+
+ # fcronsighup needs to be suid root, because it sends a HUP to the
+ # running fcron daemon, but only has to be called by the fcron group
+ # anyway
+ fowners ${rootuser}:fcron \
+ /usr/libexec/fcronsighup \
+ /etc/fcron/fcron.{allow,deny,conf} \
+ /etc/fcron
+
+ fperms 6770 /var/spool/fcron
+ fperms 6775 /usr/bin/fcron{dyn,tab}
+
+ fperms 4710 /usr/libexec/fcronsighup
+
+ fperms 0750 /etc/fcron
+ fperms 0640 /etc/fcron/fcron.{allow,deny,conf}
+
+ pamd_mimic system-services fcron auth account session
+ cat > "${T}"/fcrontab.pam <<- EOF
+ # Don't ask for the user's password; fcrontab will only allow to
+ # change user if running as root.
+ auth sufficient pam_permit.so
+
+ # Still use the system-auth stack for account and session as the
+ # sysadmin might have set up stuff properly, and also avoids
+ # sidestepping limits (since fcrontab will run \$EDITOR).
+ account include system-auth
+ session include system-auth
+ EOF
+ newpamd "${T}"/fcrontab.pam fcrontab
+
+ newinitd "${FILESDIR}"/fcron.init.3 fcron
+ systemd_newunit "${S}/script/fcron.init.systemd" fcron.service
+
+ dodoc MANIFEST VERSION "${FILESDIR}"/crontab \
+ doc/en/txt/{readme,thanks,faq,todo,relnotes,changes}.txt
+ newdoc files/fcron.conf fcron.conf.sample
+ dohtml doc/en/HTML/*.html
+ doman doc/en/man/*.{1,5,8}
+
+ for lang in fr; do
+ use linguas_${lang} || continue
+
+ doman -i18n=${lang} doc/${lang}/man/*.{1,5,8} || die
+ docinto html/${lang}
+ dohtml doc/${lang}/HTML/*.html || die
+ done
+}
+
+pkg_postinst() {
+ elog "If it's the first time you install fcron make sure to execute"
+ elog " emerge --config ${CATEGORY}/${PN}"
+ elog "to configure the proper settings."
+ if ! use system-crontab; then
+ echo ""
+ ewarn "Remember that fcron will *not* use /etc/cron.d in this configuration"
+ echo ""
+ fi
+}
+
+pkg_config() {
+ if [[ $(fcrontab -l -u systab 2>/dev/null) ]]; then
+ eerror "We're not going to make any change to your systab as long as"
+ eerror "it contains data; please clear it before proceeding."
+ return 1
+ fi
+
+ if use system-crontab; then
+ elog "This is going to set up fcron to execute check_system_crontabs."
+ elog "In this configuration, you're no longer free to edit the systab"
+ elog "at your leisure, as it'll be rewritten the moment the crontabs"
+ elog "are modified."
+ /usr/libexec/check_system_crontabs -v -i -f
+ else
+ elog "This is going to set up fcron to set up a default systab that"
+ elog "executes /etc/cron.{hourly,daily,weekly,monthly}."
+ fcrontab -u systab - <<- EOF
+ 0 * * * * rm -f /var/spool/cron/lastrun/cron.hourly
+ 1 3 * * * rm -f /var/spool/cron/lastrun/cron.daily
+ 15 4 * * 6 rm -f /var/spool/cron/lastrun/cron.weekly
+ 30 5 1 * * rm -f /var/spool/cron/lastrun/cron.monthly
+ EOF
+ fi
+}