summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-08 04:34:26 +0100
committerSam James <sam@gentoo.org>2022-09-10 12:28:03 +0100
commit4b7575b3f13e546dd2431d0ab8db699935392bdb (patch)
tree1c127635eade2109b74a29e9f857a4b137cf02c0 /virtual/libcrypt
parentsys-libs/libxcrypt: wire up musl USE=system support (diff)
downloadgentoo-4b7575b3f13e546dd2431d0ab8db699935392bdb.tar.gz
gentoo-4b7575b3f13e546dd2431d0ab8db699935392bdb.tar.bz2
gentoo-4b7575b3f13e546dd2431d0ab8db699935392bdb.zip
virtual/libcrypt: add 2-r1 with support for musl
This brings musl in line with the changes we made for glibc a while ago. The situation with glibc is a bit different because the migration is mandatory there, while we're just strongly recommending it for musl because sys-libs/libxcrypt[-system] causes headaches (see linked PAM bug for an example, but I've also hit a similar issue with Python yesterday). Bug: https://bugs.gentoo.org/867991 Bug: https://bugs.gentoo.org/699422 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'virtual/libcrypt')
-rw-r--r--virtual/libcrypt/libcrypt-2-r1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/virtual/libcrypt/libcrypt-2-r1.ebuild b/virtual/libcrypt/libcrypt-2-r1.ebuild
new file mode 100644
index 000000000000..ed66eaa1a4fd
--- /dev/null
+++ b/virtual/libcrypt/libcrypt-2-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for libcrypt.so"
+
+SLOT="0/2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND="
+ !prefix-guest? (
+ elibc_glibc? ( sys-libs/libxcrypt[system(-),static-libs(-)?,${MULTILIB_USEDEP}] )
+ elibc_musl? ( sys-libs/libxcrypt[system(-),static-libs(-)?] )
+ )
+ elibc_Cygwin? ( sys-libs/cygwin-crypt )
+"