summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-04-01 21:57:14 +0100
committerMarek Szuba <marecki@gentoo.org>2020-04-01 22:15:01 +0100
commit6e97d56ed0340ed41cff2d61e3c2d559db6538c1 (patch)
tree120358fa7e0aeeb0d4792234449d23b1ff2d6815 /virtual/opencl
parentvirtual/opencl: add dev-libs/ocl-icd as the fallback provider (diff)
downloadgentoo-6e97d56ed0340ed41cff2d61e3c2d559db6538c1.tar.gz
gentoo-6e97d56ed0340ed41cff2d61e3c2d559db6538c1.tar.bz2
gentoo-6e97d56ed0340ed41cff2d61e3c2d559db6538c1.zip
virtual/opencl: fix amdgpu dependencies
1. Not sure if this is due to what upstream supports (like for both Intel providers) or because it has not been implemented - but either way, as of 2020-04-01 dev-libs/rocm-opencl-runtime neither is keyworded x86 nor supports multilib on amd64; 2. Conversely, dev-libs/amdgpu-pro-opencl does both so in order for multilib to work properly it should be passed $MULTILIB_USEDEP. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'virtual/opencl')
-rw-r--r--virtual/opencl/opencl-2.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/virtual/opencl/opencl-2.ebuild b/virtual/opencl/opencl-2.ebuild
index 50fcd113e316..51ea03746dee 100644
--- a/virtual/opencl/opencl-2.ebuild
+++ b/virtual/opencl/opencl-2.ebuild
@@ -11,7 +11,7 @@ KEYWORDS="amd64 x86"
CARDS=( amdgpu i965 nvidia r600 radeonsi )
IUSE="${CARDS[@]/#/video_cards_}"
-# intel-neo and intel-ocl-sdk are amd64-only
+# intel-neo, intel-ocl-sdk and rocm-opencl-runtime are abi_x86_64-only
# ocl-icd is essentially a dummy/you-are-on-your-own provider - it installs
# header files to include in the source code and a library to link against
# but does not support any actual devices
@@ -21,8 +21,8 @@ RDEPEND="app-eselect/eselect-opencl
abi_x86_64? ( !abi_x86_32? ( dev-libs/intel-neo ) )
)
video_cards_amdgpu? ( || (
- dev-libs/rocm-opencl-runtime
- dev-libs/amdgpu-pro-opencl ) )
+ abi_x86_64? ( !abi_x86_32? ( dev-libs/rocm-opencl-runtime ) )
+ dev-libs/amdgpu-pro-opencl[${MULTILIB_USEDEP}] ) )
video_cards_nvidia? ( || (
>=x11-drivers/nvidia-drivers-290.10-r2[uvm(-)]
>=media-libs/mesa-9.1.6[opencl,X(+),${MULTILIB_USEDEP}] ) )