summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-10 11:33:30 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-10 11:54:09 +0100
commit32100e32a0b211f4ec778cb4908e45585e29a36b (patch)
treebaec9c92be2ad66cb79d6ca164918279fdda0077 /virtual/python-dnspython/python-dnspython-1.ebuild
parentwww-servers/tornado: Version Bump (diff)
downloadgentoo-32100e32a0b211f4ec778cb4908e45585e29a36b.tar.gz
gentoo-32100e32a0b211f4ec778cb4908e45585e29a36b.tar.bz2
gentoo-32100e32a0b211f4ec778cb4908e45585e29a36b.zip
Sanitize virtual namespace of python packages
Rename virtual/MODULE to virtual/python-MODULE Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'virtual/python-dnspython/python-dnspython-1.ebuild')
-rw-r--r--virtual/python-dnspython/python-dnspython-1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/virtual/python-dnspython/python-dnspython-1.ebuild b/virtual/python-dnspython/python-dnspython-1.ebuild
new file mode 100644
index 000000000000..14cf6ee264d7
--- /dev/null
+++ b/virtual/python-dnspython/python-dnspython-1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit python-r1
+
+DESCRIPTION="A virtual for dnspython, for Python 2 & 3"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !dev-python/dnspython:0
+ $(python_gen_cond_dep 'dev-python/dnspython:py2[${PYTHON_USEDEP}]' python2*)
+ $(python_gen_cond_dep 'dev-python/dnspython:py3[${PYTHON_USEDEP}]' python3*)"
+DEPEND="!dev-python/dnspython:0"