summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-02-28 12:30:49 -0500
committerBrian Evans <grknight@gentoo.org>2018-02-28 12:30:49 -0500
commit8b6b21e5653ed81d841950eb1583120efaede280 (patch)
tree6d89d7c2de5a06cbb1db321edcb7a854f1805b8f /virtual
parentbase/package.use.mask: Adjust mariadb client-libs mask to prevent blockers (diff)
downloadgentoo-8b6b21e5653ed81d841950eb1583120efaede280.tar.gz
gentoo-8b6b21e5653ed81d841950eb1583120efaede280.tar.bz2
gentoo-8b6b21e5653ed81d841950eb1583120efaede280.zip
virtual/mysql: Restore 5.6-r6 to fix dependencies
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'virtual')
-rw-r--r--virtual/mysql/mysql-5.6-r6.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/virtual/mysql/mysql-5.6-r6.ebuild b/virtual/mysql/mysql-5.6-r6.ebuild
new file mode 100644
index 000000000000..c0766fda8bf5
--- /dev/null
+++ b/virtual/mysql/mysql-5.6-r6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for MySQL database server"
+SLOT="0/18"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="embedded static static-libs"
+
+RDEPEND="
+ virtual/libmysqlclient[static-libs?,${MULTILIB_USEDEP}]
+ embedded? (
+ || (
+ =dev-db/mariadb-10.1*[client-libs(+),embedded,static=]
+ =dev-db/mariadb-10.0*[client-libs(+),embedded,static=]
+ =dev-db/mysql-${PV}*[client-libs(+),embedded,static=]
+ =dev-db/percona-server-${PV}*[client-libs(+),embedded,static=]
+ =dev-db/mariadb-galera-10.0*[client-libs(+),embedded,static=]
+ =dev-db/mysql-cluster-7.3*[client-libs(+),embedded,static=]
+ )
+ )
+ !embedded? (
+ || (
+ =dev-db/mariadb-10.1*[-embedded,static=]
+ =dev-db/mariadb-10.0*[-embedded,static=]
+ =dev-db/mysql-${PV}*[-embedded,static=]
+ =dev-db/percona-server-${PV}*[-embedded,static=]
+ =dev-db/mariadb-galera-10.0*[-embedded,static=]
+ =dev-db/mysql-cluster-7.3*[-embedded,static=]
+ )
+ )
+"