summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2019-11-24 20:43:04 -0500
committerNick Sarnie <sarnex@gentoo.org>2019-11-24 20:46:43 -0500
commitaecda2f12d7476116b5223b755f5e52a1856363d (patch)
tree81990fc2fccf312f3af3d81dd04df043507fef96 /virtual
parentsys-libs/glibc: New 2.29 patchset / revbump (diff)
downloadgentoo-aecda2f12d7476116b5223b755f5e52a1856363d.tar.gz
gentoo-aecda2f12d7476116b5223b755f5e52a1856363d.tar.bz2
gentoo-aecda2f12d7476116b5223b755f5e52a1856363d.zip
virtual/wine: Remove reference to last rited package
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'virtual')
-rw-r--r--virtual/wine/wine-0-r7.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/virtual/wine/wine-0-r7.ebuild b/virtual/wine/wine-0-r7.ebuild
new file mode 100644
index 000000000000..c169693fcdbb
--- /dev/null
+++ b/virtual/wine/wine-0-r7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Virtual for Wine that supports multiple variants and slotting"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+abi_x86_32 +abi_x86_64 staging"
+
+REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )"
+
+# Note, the ordering here is intentional, to take advantage of the short-circuit
+# logic of portage, to enforce wine-vanilla as default for new users. The idea
+# behind this is that some USE flags may pull in 3rd-party patchsets, so default
+# of vanilla prevents that.
+RDEPEND="
+ staging? ( || (
+ app-emulation/wine-staging[staging]
+ ) )
+ || (
+ app-emulation/wine-vanilla[abi_x86_32=,abi_x86_64=]
+ app-emulation/wine-staging[abi_x86_32=,abi_x86_64=]
+ )
+ !app-emulation/wine:0"