summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-05 10:36:11 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-05 11:55:46 +0100
commitcd3f25deb13cf4d6c9d721d515dbf772a988426f (patch)
tree423ea2268525779097c812fd1bef71091c26dc89 /virtual
parentsys-apps/openrc: arm stable wrt bug #704600 (diff)
downloadgentoo-cd3f25deb13cf4d6c9d721d515dbf772a988426f.tar.gz
gentoo-cd3f25deb13cf4d6c9d721d515dbf772a988426f.tar.bz2
gentoo-cd3f25deb13cf4d6c9d721d515dbf772a988426f.zip
*/*: Clean PYTHON_COMPAT of obsolete impls
Closes: https://github.com/gentoo/gentoo/pull/14246 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'virtual')
-rw-r--r--virtual/python-backports_abc/python-backports_abc-0.ebuild4
-rw-r--r--virtual/python-cffi/python-cffi-0.ebuild4
-rw-r--r--virtual/python-enum34/python-enum34-2.ebuild4
-rw-r--r--virtual/python-funcsigs/python-funcsigs-2-r1.ebuild2
-rw-r--r--virtual/python-futures/python-futures-0.ebuild4
-rw-r--r--virtual/python-futures/python-futures-1.ebuild4
-rw-r--r--virtual/python-greenlet/python-greenlet-1.0-r1.ebuild4
-rw-r--r--virtual/python-ipaddress/python-ipaddress-1.0-r1.ebuild4
-rw-r--r--virtual/python-pathlib/python-pathlib-1.0.ebuild4
-rw-r--r--virtual/python-singledispatch/python-singledispatch-0.ebuild4
-rw-r--r--virtual/python-typing/python-typing-0-r1.ebuild4
-rw-r--r--virtual/python-unittest-mock/python-unittest-mock-1.ebuild4
12 files changed, 23 insertions, 23 deletions
diff --git a/virtual/python-backports_abc/python-backports_abc-0.ebuild b/virtual/python-backports_abc/python-backports_abc-0.ebuild
index 3060d6c14884..66ce89cef2b8 100644
--- a/virtual/python-backports_abc/python-backports_abc-0.ebuild
+++ b/virtual/python-backports_abc/python-backports_abc-0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
inherit python-r1
diff --git a/virtual/python-cffi/python-cffi-0.ebuild b/virtual/python-cffi/python-cffi-0.ebuild
index dcf236bb4a8e..340eac398187 100644
--- a/virtual/python-cffi/python-cffi-0.ebuild
+++ b/virtual/python-cffi/python-cffi-0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
inherit python-r1
diff --git a/virtual/python-enum34/python-enum34-2.ebuild b/virtual/python-enum34/python-enum34-2.ebuild
index 1358450bbe9b..498bd7db165b 100644
--- a/virtual/python-enum34/python-enum34-2.ebuild
+++ b/virtual/python-enum34/python-enum34-2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
inherit python-r1
diff --git a/virtual/python-funcsigs/python-funcsigs-2-r1.ebuild b/virtual/python-funcsigs/python-funcsigs-2-r1.ebuild
index 38bf30e8bc75..593d63d0c613 100644
--- a/virtual/python-funcsigs/python-funcsigs-2-r1.ebuild
+++ b/virtual/python-funcsigs/python-funcsigs-2-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
inherit python-r1
diff --git a/virtual/python-futures/python-futures-0.ebuild b/virtual/python-futures/python-futures-0.ebuild
index 64978329bd47..20dcf9c1b0d4 100644
--- a/virtual/python-futures/python-futures-0.ebuild
+++ b/virtual/python-futures/python-futures-0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
inherit python-r1
diff --git a/virtual/python-futures/python-futures-1.ebuild b/virtual/python-futures/python-futures-1.ebuild
index f58e405f5bf9..7affbf4b4864 100644
--- a/virtual/python-futures/python-futures-1.ebuild
+++ b/virtual/python-futures/python-futures-1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
inherit python-r1
diff --git a/virtual/python-greenlet/python-greenlet-1.0-r1.ebuild b/virtual/python-greenlet/python-greenlet-1.0-r1.ebuild
index 0144bc67fa53..71bb8dd147c3 100644
--- a/virtual/python-greenlet/python-greenlet-1.0-r1.ebuild
+++ b/virtual/python-greenlet/python-greenlet-1.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
inherit python-r1
diff --git a/virtual/python-ipaddress/python-ipaddress-1.0-r1.ebuild b/virtual/python-ipaddress/python-ipaddress-1.0-r1.ebuild
index cc3091a0a4ef..607e461a5e8c 100644
--- a/virtual/python-ipaddress/python-ipaddress-1.0-r1.ebuild
+++ b/virtual/python-ipaddress/python-ipaddress-1.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
inherit python-r1
diff --git a/virtual/python-pathlib/python-pathlib-1.0.ebuild b/virtual/python-pathlib/python-pathlib-1.0.ebuild
index 80943c77076a..9ed374b356c2 100644
--- a/virtual/python-pathlib/python-pathlib-1.0.ebuild
+++ b/virtual/python-pathlib/python-pathlib-1.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
inherit python-r1
diff --git a/virtual/python-singledispatch/python-singledispatch-0.ebuild b/virtual/python-singledispatch/python-singledispatch-0.ebuild
index de4f135df52e..b18ceb402afa 100644
--- a/virtual/python-singledispatch/python-singledispatch-0.ebuild
+++ b/virtual/python-singledispatch/python-singledispatch-0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
inherit python-r1
diff --git a/virtual/python-typing/python-typing-0-r1.ebuild b/virtual/python-typing/python-typing-0-r1.ebuild
index 779c0a176e6c..adefd4087421 100644
--- a/virtual/python-typing/python-typing-0-r1.ebuild
+++ b/virtual/python-typing/python-typing-0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7,3_8} pypy{,3} )
+PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} pypy3 )
inherit python-r1
diff --git a/virtual/python-unittest-mock/python-unittest-mock-1.ebuild b/virtual/python-unittest-mock/python-unittest-mock-1.ebuild
index 2ea3d0e53312..f688b601c41a 100644
--- a/virtual/python-unittest-mock/python-unittest-mock-1.ebuild
+++ b/virtual/python-unittest-mock/python-unittest-mock-1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
inherit python-r1