summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mod_auth_imap2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mod_auth_imap2')
-rw-r--r--www-apache/mod_auth_imap2/Manifest1
-rw-r--r--www-apache/mod_auth_imap2/files/10_mod_auth_imap.conf36
-rw-r--r--www-apache/mod_auth_imap2/metadata.xml5
-rw-r--r--www-apache/mod_auth_imap2/mod_auth_imap2-2.2.0.ebuild28
4 files changed, 70 insertions, 0 deletions
diff --git a/www-apache/mod_auth_imap2/Manifest b/www-apache/mod_auth_imap2/Manifest
new file mode 100644
index 000000000000..c72f39db32c2
--- /dev/null
+++ b/www-apache/mod_auth_imap2/Manifest
@@ -0,0 +1 @@
+DIST mod_auth_imap2-2.2.0.tar.gz 12787 SHA256 9642a13932010b9587d7b2263f21bed29602253bac18cb6c8847385d13d3cce0
diff --git a/www-apache/mod_auth_imap2/files/10_mod_auth_imap.conf b/www-apache/mod_auth_imap2/files/10_mod_auth_imap.conf
new file mode 100644
index 000000000000..c82bf9e04518
--- /dev/null
+++ b/www-apache/mod_auth_imap2/files/10_mod_auth_imap.conf
@@ -0,0 +1,36 @@
+<IfDefine AUTH_IMAP>
+LoadModule auth_imap_module modules/mod_auth_imap.so
+
+<Directory /var/www/localhost/htdocs>
+ # For Apache 2.2 the mod_auth_basic module is now set to
+ # be authoritative, and must be disabled if other modules
+ # are used for authentication.
+ #AuthBasicAuthoritative Off
+
+ # Turn on IMAP Authentication
+ #Auth_IMAP_Enabled on
+
+ # Give a name to the authentication domain, whatever you want:
+ #AuthName "something.com"
+
+ # Only basic authentication is supported for now:
+ #AuthType Basic
+
+ # If you feel like it, restrict the users or allow all "valid-user"
+ #Require user user1 user2
+
+ # Make IMAP Authentication authoritative for this .htaccess file:
+ #Auth_IMAP_Authoritative on
+
+ # Set the IMAP Server to which you want to connect (default=localhost):
+ #Auth_IMAP_Server imap.something.com
+
+ # Set the port on which the imap server is running (default=143):
+ #Auth_IMAP_Port 143
+
+ # Turn on some extra logging (login attempts, etc.) in Apache's Error Log
+ #Auth_IMAP_Log on
+</Directory>
+</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_auth_imap2/metadata.xml b/www-apache/mod_auth_imap2/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/www-apache/mod_auth_imap2/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/www-apache/mod_auth_imap2/mod_auth_imap2-2.2.0.ebuild b/www-apache/mod_auth_imap2/mod_auth_imap2-2.2.0.ebuild
new file mode 100644
index 000000000000..aa36c707af83
--- /dev/null
+++ b/www-apache/mod_auth_imap2/mod_auth_imap2-2.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit apache-module
+
+MY_PN="${PN/imap2/imap}"
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="An Apache2 module to provide authentication via an IMAP Mail server"
+HOMEPAGE="http://ben.brillat.net/projects/mod_auth_imap/"
+SRC_URI="http://ben.brillat.net/files/projects/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+APXS2_ARGS="-c ${MY_PN}.c"
+
+APACHE2_MOD_CONF="10_${MY_PN}"
+APACHE2_MOD_DEFINE="AUTH_IMAP"
+APACHE2_MOD_FILE=".libs/${MY_PN}.so"
+
+DOCFILES="CHANGELOG README examples/*"
+
+need_apache2