summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-11-27 13:49:57 +0100
committerMarek Szuba <marecki@gentoo.org>2021-11-27 14:04:14 +0100
commitf83111f8ca9ba399c7e7b1479c41aa3c8d489fa3 (patch)
tree31d03402e9c9296e4d77b9e1ce8271baf96f5e85 /www-apache/mod_auth_tkt
parentwww-apache/mod_auth_radius: add 1.6.0, remove 1.5.8 (diff)
downloadgentoo-f83111f8ca9ba399c7e7b1479c41aa3c8d489fa3.tar.gz
gentoo-f83111f8ca9ba399c7e7b1479c41aa3c8d489fa3.tar.bz2
gentoo-f83111f8ca9ba399c7e7b1479c41aa3c8d489fa3.zip
www-apache/mod_auth_tkt: update EAPI 5 -> 7
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'www-apache/mod_auth_tkt')
-rw-r--r--www-apache/mod_auth_tkt/mod_auth_tkt-2.1.0-r2.ebuild (renamed from www-apache/mod_auth_tkt/mod_auth_tkt-2.1.0-r1.ebuild)21
1 files changed, 11 insertions, 10 deletions
diff --git a/www-apache/mod_auth_tkt/mod_auth_tkt-2.1.0-r1.ebuild b/www-apache/mod_auth_tkt/mod_auth_tkt-2.1.0-r2.ebuild
index e7ec743532d2..a20ae2253536 100644
--- a/www-apache/mod_auth_tkt/mod_auth_tkt-2.1.0-r1.ebuild
+++ b/www-apache/mod_auth_tkt/mod_auth_tkt-2.1.0-r2.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit apache-module epatch
+EAPI=7
+
+inherit apache-module depend.apache
DESCRIPTION="Apache module for cookie based authentication"
HOMEPAGE="http://www.openfusion.com.au/labs/mod_auth_tkt/"
@@ -11,10 +12,8 @@ SRC_URI="http://www.openfusion.com.au/labs/dist/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
DEPEND="dev-lang/perl"
-RDEPEND=""
APACHE2_MOD_CONF="10_${PN}"
APACHE2_MOD_DEFINE="AUTH_TKT"
@@ -24,20 +23,22 @@ DOCFILES="README"
# test suite is completely broken
RESTRICT="test"
+PATCHES=(
+ "${FILESDIR}"/${P}-apache-2.4.patch
+)
+
need_apache2
-src_prepare() {
- epatch "${FILESDIR}"/${P}-apache-2.4.patch
+# Work around Bug #616612
+pkg_setup() {
+ _init_apache2
+ _init_apache2_late
}
src_configure() {
./configure --apachever=2.2 --apxs=${APXS}
}
-src_compile() {
- emake
-}
-
src_install() {
apache-module_src_install
pod2man --section=5 --release=${PV} doc/${PN}.{pod,5}