summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-09-06 10:42:31 -0400
committerCraig Andrews <candrews@gentoo.org>2019-09-06 10:43:06 -0400
commitc96c2de5113e1c6d4741c4c1f9df4256e7210bc2 (patch)
tree2e0eb74514ab1d8405d850c6264a5824f88fa78f /www-apache/mod_authz_unixgroup/mod_authz_unixgroup-9999.ebuild
parentmail-client/thunderbird: adjust media-libs/libvpx version constraint (diff)
downloadgentoo-c96c2de5113e1c6d4741c4c1f9df4256e7210bc2.tar.gz
gentoo-c96c2de5113e1c6d4741c4c1f9df4256e7210bc2.tar.bz2
gentoo-c96c2de5113e1c6d4741c4c1f9df4256e7210bc2.zip
www-apache/mod_authz_unixgroup: An Apache2 authorization DSO using unix groups
Closes: https://bugs.gentoo.org/693592 Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apache/mod_authz_unixgroup/mod_authz_unixgroup-9999.ebuild')
-rw-r--r--www-apache/mod_authz_unixgroup/mod_authz_unixgroup-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/www-apache/mod_authz_unixgroup/mod_authz_unixgroup-9999.ebuild b/www-apache/mod_authz_unixgroup/mod_authz_unixgroup-9999.ebuild
new file mode 100644
index 000000000000..7c9081bf3575
--- /dev/null
+++ b/www-apache/mod_authz_unixgroup/mod_authz_unixgroup-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit apache-module
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/phokz/mod-auth-external.git"
+ inherit git-r3
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/phokz/mod-auth-external/archive/${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/mod-auth-external-${P}"
+fi
+
+DESCRIPTION="An Apache2 authorization DSO using unix groups"
+HOMEPAGE="https://github.com/phokz/mod-auth-external"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+need_apache2_4
+
+DOCFILES="CHANGES INSTALL README NOTICE"
+
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="AUTHZ_UNIXGROUP"
+
+pkg_setup() {
+ _init_apache2
+ _init_apache2_late
+}