summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-25 23:01:40 +0000
committerSam James <sam@gentoo.org>2020-09-25 23:03:42 +0000
commit19091788afa73db48e6ec522e807ec6767dbbcfa (patch)
treec86d7c5cf2f01fc73b48eee027fe17d6d23afdeb /www-apache/mod_common_redirect
parentdev-perl/autovivification: Cleanup old 0.180.0 (diff)
downloadgentoo-19091788afa73db48e6ec522e807ec6767dbbcfa.tar.gz
gentoo-19091788afa73db48e6ec522e807ec6767dbbcfa.tar.bz2
gentoo-19091788afa73db48e6ec522e807ec6767dbbcfa.zip
www-apache/mod_common_redirect: port EAPI 4->6
We cannot go to EAPI 7 yet because of the apache-module and depend.apache eclasses. Bug: https://bugs.gentoo.org/724220 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-apache/mod_common_redirect')
-rw-r--r--www-apache/mod_common_redirect/mod_common_redirect-0.1.1-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/www-apache/mod_common_redirect/mod_common_redirect-0.1.1-r1.ebuild b/www-apache/mod_common_redirect/mod_common_redirect-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..65fbdd48126d
--- /dev/null
+++ b/www-apache/mod_common_redirect/mod_common_redirect-0.1.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit apache-module
+
+GITHUB_AUTHOR="hollow"
+GITHUB_PROJECT="mod_common_redirect"
+GITHUB_COMMIT="595a370"
+DESCRIPTION="mod_common_redirect implements common redirects without mod_rewrite overhead"
+HOMEPAGE="https://github.com/hollow/mod_common_redirect"
+SRC_URI="https://nodeload.github.com/${GITHUB_AUTHOR}/${GITHUB_PROJECT}/tarball/v${PV} -> ${P}.tar.gz"
+S="${WORKDIR}"/${GITHUB_AUTHOR}-${GITHUB_PROJECT}-${GITHUB_COMMIT}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+APACHE2_MOD_CONF="20_${PN}"
+APACHE2_MOD_DEFINE="COMMON_REDIRECT"
+
+need_apache2
+
+src_install() {
+ APACHE2_MOD_CONF="20_${PN}"
+ APACHE2_MOD_DEFINE="COMMON_REDIRECT"
+ APACHE_MODULESDIR="/usr/$(get_libdir)/apache2/modules"
+ apache-module_src_install
+}