summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mod_fastcgi_handler
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mod_fastcgi_handler')
-rw-r--r--www-apache/mod_fastcgi_handler/Manifest1
-rw-r--r--www-apache/mod_fastcgi_handler/files/20_mod_fastcgi_handler.conf5
-rw-r--r--www-apache/mod_fastcgi_handler/metadata.xml11
-rw-r--r--www-apache/mod_fastcgi_handler/mod_fastcgi_handler-0.6.ebuild32
4 files changed, 49 insertions, 0 deletions
diff --git a/www-apache/mod_fastcgi_handler/Manifest b/www-apache/mod_fastcgi_handler/Manifest
new file mode 100644
index 000000000000..e221114d54b0
--- /dev/null
+++ b/www-apache/mod_fastcgi_handler/Manifest
@@ -0,0 +1 @@
+DIST mod_fastcgi_handler-0.6.tar.gz 10980 SHA256 1d1676005a50c77101681c054df3e76939b6885060027882d4a506141637c39e
diff --git a/www-apache/mod_fastcgi_handler/files/20_mod_fastcgi_handler.conf b/www-apache/mod_fastcgi_handler/files/20_mod_fastcgi_handler.conf
new file mode 100644
index 000000000000..dd07c33cc100
--- /dev/null
+++ b/www-apache/mod_fastcgi_handler/files/20_mod_fastcgi_handler.conf
@@ -0,0 +1,5 @@
+<IfDefine FASTCGI_HANDLER>
+LoadModule fastcgi_handler_module modules/mod_fastcgi_handler.so
+</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_fastcgi_handler/metadata.xml b/www-apache/mod_fastcgi_handler/metadata.xml
new file mode 100644
index 000000000000..52ae9191ee8a
--- /dev/null
+++ b/www-apache/mod_fastcgi_handler/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>neurogeek@gentoo.org</email>
+ <name>Jesus Rivero</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">hollow/mod_fastcgi_handler</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/www-apache/mod_fastcgi_handler/mod_fastcgi_handler-0.6.ebuild b/www-apache/mod_fastcgi_handler/mod_fastcgi_handler-0.6.ebuild
new file mode 100644
index 000000000000..8872d9b2b53c
--- /dev/null
+++ b/www-apache/mod_fastcgi_handler/mod_fastcgi_handler-0.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+GITHUB_AUTHOR="hollow"
+GITHUB_PROJECT="mod_fastcgi_handler"
+GITHUB_COMMIT="c5e075b"
+
+inherit apache-module
+
+DESCRIPTION="A simple FastCGI handler module"
+HOMEPAGE="http://github.com/hollow/mod_fastcgi_handler"
+SRC_URI="http://nodeload.github.com/${GITHUB_AUTHOR}/${GITHUB_PROJECT}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}"/${GITHUB_AUTHOR}-${GITHUB_PROJECT}-${GITHUB_COMMIT}
+
+APACHE2_MOD_CONF="20_${PN}"
+APACHE2_MOD_DEFINE="FASTCGI_HANDLER"
+
+APXS2_ARGS="-o ${PN}.so -c *.c"
+
+need_apache2