summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-01-16 01:23:39 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-01-16 01:24:05 +0100
commit90383c0bdffc4b6bca6df5262b30e9f77b98b23f (patch)
tree982beab8b68185a35c97519dc583f690c162c6a2 /www-apache/mod_gnutls/mod_gnutls-0.8.3-r1.ebuild
parentgames-roguelike/dwarf-fortress: Version bump to 0.44.05, add (diff)
downloadgentoo-90383c0bdffc4b6bca6df5262b30e9f77b98b23f.tar.gz
gentoo-90383c0bdffc4b6bca6df5262b30e9f77b98b23f.tar.bz2
gentoo-90383c0bdffc4b6bca6df5262b30e9f77b98b23f.zip
www-apache/mod_gnutls: Revbump to prevent installation of /mod_gnutls.so
Downgraded ebuild to EAPI-5 until further debugging. Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'www-apache/mod_gnutls/mod_gnutls-0.8.3-r1.ebuild')
-rw-r--r--www-apache/mod_gnutls/mod_gnutls-0.8.3-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/www-apache/mod_gnutls/mod_gnutls-0.8.3-r1.ebuild b/www-apache/mod_gnutls/mod_gnutls-0.8.3-r1.ebuild
new file mode 100644
index 000000000000..1d6985d4f075
--- /dev/null
+++ b/www-apache/mod_gnutls/mod_gnutls-0.8.3-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# WARNING! Don't switch to EAPI-6 without checking paths of installed files
+# carefully. The .so file might get installed into /
+EAPI=5
+inherit autotools apache-module
+
+DESCRIPTION="mod_gnutls uses GnuTLS for SSL/TLS encryption in Apache2 (compare to mod_ssl)"
+HOMEPAGE="https://mod.gnutls.org/"
+SRC_URI="https://mod.gnutls.org/downloads/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+CDEPEND=">=net-libs/gnutls-3.3.0:="
+DEPEND="${CDEPEND}
+ test? ( app-crypt/monkeysphere )"
+RDEPEND="${CDEPEND}"
+
+# Fails because gpg-agent cannot be accessed
+RESTRICT="test"
+
+APACHE2_MOD_CONF="47_${PN}"
+APACHE2_MOD_DEFINE="GNUTLS"
+
+DOCFILES="CHANGELOG NOTICE README"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-apxs="${APXS}"
+ --disable-strict
+ --disable-doxygen-dot
+ --disable-doxygen-doc
+ --disable-doxygen-html
+ --disable-doxygen-pdf
+ ac_cv_path_UNSHARE=no
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ apache-module_src_install
+}