summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@integralblue.com>2017-08-04 09:26:03 -0400
committerDavid Seifert <soap@gentoo.org>2017-08-07 19:12:11 +0200
commit4edd88f5877644b95f538aa1be9a0c74019f0518 (patch)
tree9dad653726fdb10d01a4c26d4a0e025a297ae5fd /www-apache/mod_h2
parentprofiles: Drop mask as it was set for pacman-4.x in unmaintained state. (diff)
downloadgentoo-4edd88f5877644b95f538aa1be9a0c74019f0518.tar.gz
gentoo-4edd88f5877644b95f538aa1be9a0c74019f0518.tar.bz2
gentoo-4edd88f5877644b95f538aa1be9a0c74019f0518.zip
www-apache/mod_h2: version 1.10.10, use EAPI=6
Package-Manager: Portage-2.3.6, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/5296
Diffstat (limited to 'www-apache/mod_h2')
-rw-r--r--www-apache/mod_h2/Manifest1
-rw-r--r--www-apache/mod_h2/mod_h2-1.10.10.ebuild47
-rw-r--r--www-apache/mod_h2/mod_h2-9999.ebuild16
3 files changed, 55 insertions, 9 deletions
diff --git a/www-apache/mod_h2/Manifest b/www-apache/mod_h2/Manifest
index 92a0c89b1e91..3a26e01798e0 100644
--- a/www-apache/mod_h2/Manifest
+++ b/www-apache/mod_h2/Manifest
@@ -1,2 +1,3 @@
+DIST mod_http2-1.10.10.tar.gz 528560 SHA256 9fa881c7f2cdc955b790406bebf6e0542d35b91aeb2a400e21c244e853971ee8 SHA512 b4b9e734ed35ca63fa114462f1adb358bb73e4cbd8df95ab28c4518b8f7db40233f4ba13bc2194847eb9c1adbc3eb86fc63cbb56389fc0867767658d4d8ba77b WHIRLPOOL ee319ff6ba21832de525efa15ff1a2cd2bfef7ba80e60713342af63edf2a76d4c60c76f6b63ca172fcd33b45e728711f12646f08cc8f932f2a0802771dd95ca2
DIST mod_http2-1.4.7.tar.gz 476716 SHA256 0d51a019917aa6bf7866cf23bf837626592ad0e74408eb341d070982cb88380a SHA512 6d91d8f73de4a571dc9ac24328b2f7214afcc9a3a00cbf93a74954533a45b647480f96f0cb1c85d767e980080b21561891a55b16943b0369a0fe2573bba1b54f WHIRLPOOL 0b81b8baf871ff043e972c65c685ae9f18737c0909bff65528a6ea3dd56735a2230c9dda67879a5684e867681fc6487f483ef006611397061b367bc275793ad6
DIST mod_http2-1.5.6.tar.gz 502108 SHA256 73c11780e82e65c11e71e5a44685c22a7d8f07203d55dca094ea61d7a5bbaffc SHA512 8cc8894d56e32489f8e3064145cb527a415723131bdefd99583b6678af5fc50e3d4ebbf59f4734640bef0381ac0f808c780dafb9a3fe6bb45e7af4d595470716 WHIRLPOOL a2f3efb9e7ecf657be61d46a832a1b438cdaab0e44114e8ec717d9b77e8500308e7c904248c195bb55157410a103cffff8714e0378e2d2099ecb7aa7d679a4a7
diff --git a/www-apache/mod_h2/mod_h2-1.10.10.ebuild b/www-apache/mod_h2/mod_h2-1.10.10.ebuild
new file mode 100644
index 000000000000..eaf87ecaf6b9
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-1.10.10.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit apache-module
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit autotools git-r3
+else
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/icing/mod_h2/releases/download/v${PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ >=www-servers/apache-2.4.20[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ [[ ${PV} = 9999 ]] && eautoreconf
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}
diff --git a/www-apache/mod_h2/mod_h2-9999.ebuild b/www-apache/mod_h2/mod_h2-9999.ebuild
index 48f0e8ef3707..eaf87ecaf6b9 100644
--- a/www-apache/mod_h2/mod_h2-9999.ebuild
+++ b/www-apache/mod_h2/mod_h2-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="6"
inherit apache-module
@@ -9,8 +9,9 @@ MY_P="${PN/h2/http2}-${PV}"
if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
- inherit git-2
+ inherit autotools git-r3
else
+ S="${WORKDIR}/${MY_P}"
SRC_URI="https://github.com/icing/mod_h2/releases/download/v${PV}/${MY_P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
@@ -26,14 +27,11 @@ RDEPEND=">=net-libs/nghttp2-1.0
>=www-servers/apache-2.4.20[-apache2_modules_http2,ssl?]"
DEPEND="${RDEPEND}"
-S="${WORKDIR}/${MY_P}"
-
need_apache2_4
-src_configure() {
- econf \
- --docdir='$(datarootdir)'/doc/${PF} \
- --disable-werror
+src_prepare() {
+ default
+ [[ ${PV} = 9999 ]] && eautoreconf
}
src_compile() {