summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-08-25 12:12:45 -0400
committerMike Frysinger <vapier@gentoo.org>2015-08-25 12:14:08 -0400
commit53efbaeba0d617b5f9172b61ab6642273cf0a1b4 (patch)
tree6965bca662b36a8f7dc69814f766c43a5048a03d /www-apache/mod_h2
parentwww-apache/mod_h2: drop old (diff)
downloadgentoo-53efbaeba0d617b5f9172b61ab6642273cf0a1b4.tar.gz
gentoo-53efbaeba0d617b5f9172b61ab6642273cf0a1b4.tar.bz2
gentoo-53efbaeba0d617b5f9172b61ab6642273cf0a1b4.zip
www-apache/mod_h2: version bump to 0.8.3
Diffstat (limited to 'www-apache/mod_h2')
-rw-r--r--www-apache/mod_h2/Manifest1
-rw-r--r--www-apache/mod_h2/mod_h2-0.8.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/www-apache/mod_h2/Manifest b/www-apache/mod_h2/Manifest
index 2ea5fa57e099..76bab13db910 100644
--- a/www-apache/mod_h2/Manifest
+++ b/www-apache/mod_h2/Manifest
@@ -1 +1,2 @@
DIST mod_h2-0.8.2.tar.gz 2622925 SHA256 cc4a67a0c994ce7c08319bd10bc92de7d0293ebaa0c2ece0e4cc6bc8351c06aa SHA512 19d55ab28776f551ee2df157a1ab0f72b0c5362210c5da39911e6b2cbdc7079478404e7179128a31d39c393ca32e453ed2a4db310bd4f720287e9e54046c095f WHIRLPOOL 290c368b7e69d214c805e57fc6ef5790a0a4914a71035358a3ebf1cdaf0fc69ce170b2c266a0d2174c9c0e252991aba5a0de5c5aec754bfb79e37b0fd4be57e3
+DIST mod_h2-0.8.3.tar.gz 2622525 SHA256 50867947ed80c5c876c95b318b17dcdf3b77b36a80b36ef9f4778005587ac9ed SHA512 45ab6f070189175180511cc2985dcb0ab676225b144e141698baebe53f097c6d451f2c85382f23afd0042aa4703b7f37dcb88fe5a968e3422c91b46fe5526c97 WHIRLPOOL f6b110df1831ecdf849c3c30b9a09b66ef833aa11664f2cc91747ca5a027cac72caeab4dc674f34aa4e5d3e36eafea183f81261479005aeebdb07ab0582c166b
diff --git a/www-apache/mod_h2/mod_h2-0.8.3.ebuild b/www-apache/mod_h2/mod_h2-0.8.3.ebuild
new file mode 100644
index 000000000000..2890e5a789ae
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-0.8.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit apache-module
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-2
+else
+ SRC_URI="https://github.com/icing/mod_h2/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ ssl? ( www-servers/apache[alpn] )"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_configure() {
+ econf \
+ --docdir='$(datarootdir)'/doc/${PF} \
+ --disable-werror \
+ --disable-sandbox
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_h2.conf" "75_mod_h2.conf"
+}