summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-06-21 15:13:22 -0400
committerCraig Andrews <candrews@gentoo.org>2021-06-21 15:14:27 -0400
commit89c46c8e6b4ef8302a4f112a6b220b48bc411133 (patch)
tree539201d52076f17519b5fc8e679871a05864df74 /www-apache/mod_h2
parentdev-libs/libfmt: 8.0.0 version bump (diff)
downloadgentoo-89c46c8e6b4ef8302a4f112a6b220b48bc411133.tar.gz
gentoo-89c46c8e6b4ef8302a4f112a6b220b48bc411133.tar.bz2
gentoo-89c46c8e6b4ef8302a4f112a6b220b48bc411133.zip
www-apache/mod_h2: 1.15.20 version bump
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apache/mod_h2')
-rw-r--r--www-apache/mod_h2/Manifest1
-rw-r--r--www-apache/mod_h2/mod_h2-1.15.20.ebuild49
-rw-r--r--www-apache/mod_h2/mod_h2-9999.ebuild4
3 files changed, 52 insertions, 2 deletions
diff --git a/www-apache/mod_h2/Manifest b/www-apache/mod_h2/Manifest
index 0fa225a8e516..ec31c77a3f2c 100644
--- a/www-apache/mod_h2/Manifest
+++ b/www-apache/mod_h2/Manifest
@@ -2,3 +2,4 @@ DIST mod_h2-1.15.16.tar.gz 702081 BLAKE2B 1f1ce9911c4dba5001d548b99fe08c5a13882a
DIST mod_h2-1.15.17.tar.gz 708333 BLAKE2B 7f7f4625d20dd85e88768cbc1b6347498d2d913b4e778fcac6e01ef2e6676ff4c180385610e5db990d7e9d3ceceafac7e1a08b421c7d99814f9c212b17ac8d76 SHA512 7d6af4123091171273093b4333699bda2469b3e2bd7412e226394f0dc79a5a7d684035538549e13d119c5134016c8b7a3e7aaf8559eec56ed15d849655f11521
DIST mod_h2-1.15.18.tar.gz 708704 BLAKE2B 1ad8bd317c42f517baf015cbdeb89040a743753f19a0fd6ae20a3d2f1c48ae4a76dcb926ad71060f25e64e8e89c07e7e95f938b2a346b92c7c961808816fd19f SHA512 4582e815f582c66e0d119925a1b19ecd74afedc4e7db4410a8552384ad6d2e113dc4e428fa88214ef23f0d7b0b3a64c2fa6f9a42b9e0a8b1239d891826b56cdc
DIST mod_h2-1.15.19.tar.gz 708753 BLAKE2B 9193e9b307ead341e90dffe4547de444a3f47340f23e3a7171f8a0fdbd0c5749eddfd7f9e6b3e4a3afccda521437183a8e7039a79e554a4c6e18415678dfec57 SHA512 52717d173df26faaa82e1335366de448bd0b125032066e436546027580707ba872ae07e1e4e9b8b4fc5dbd02e212441d44b96092aac8732627117e109b95671a
+DIST mod_h2-1.15.20.tar.gz 707590 BLAKE2B 245b21d55c5659ed4ada3bfa5ec369ca3154e629820980caa1badefeca05399a31fb4f94594068607af20a6936e8ac2439b23e31ddcb9db8d4bb2c907400a152 SHA512 3492b24fdcb6371a5734b85253d800baa6f1650ae3c6b4d08539ec5436cbaaee2ed41fa9515fa36a94c281048f08970b20ccb6373077251a475f6831aaae8524
diff --git a/www-apache/mod_h2/mod_h2-1.15.20.ebuild b/www-apache/mod_h2/mod_h2-1.15.20.ebuild
new file mode 100644
index 000000000000..9d7e1b600b10
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-1.15.20.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit apache-module autotools
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-r3
+else
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/icing/mod_h2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ >=www-servers/apache-2.4.48[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}
diff --git a/www-apache/mod_h2/mod_h2-9999.ebuild b/www-apache/mod_h2/mod_h2-9999.ebuild
index b158648fdb59..9d7e1b600b10 100644
--- a/www-apache/mod_h2/mod_h2-9999.ebuild
+++ b/www-apache/mod_h2/mod_h2-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -24,7 +24,7 @@ SLOT="0"
IUSE="ssl"
RDEPEND=">=net-libs/nghttp2-1.0
- >=www-servers/apache-2.4.20[-apache2_modules_http2,ssl?]"
+ >=www-servers/apache-2.4.48[-apache2_modules_http2,ssl?]"
DEPEND="${RDEPEND}"
S="${WORKDIR}/${P}"