summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-10-19 09:27:44 -0400
committerCraig Andrews <candrews@gentoo.org>2023-10-19 09:28:05 -0400
commitd872cd37bed28142809c005201f0ee5e661e64e9 (patch)
treee22205efa170a2054eaf9bc03f99e4458b3a9541 /www-apache/mod_h2
parentnet-p2p/qbittorrent: bump to 4.5.5, add openrc service & qt6 (diff)
downloadgentoo-d872cd37bed28142809c005201f0ee5e661e64e9.tar.gz
gentoo-d872cd37bed28142809c005201f0ee5e661e64e9.tar.bz2
gentoo-d872cd37bed28142809c005201f0ee5e661e64e9.zip
www-apache/mod_h2: add 2.0.25
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apache/mod_h2')
-rw-r--r--www-apache/mod_h2/Manifest1
-rw-r--r--www-apache/mod_h2/mod_h2-2.0.25.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/www-apache/mod_h2/Manifest b/www-apache/mod_h2/Manifest
index e792fff6c638..86aa3ca08232 100644
--- a/www-apache/mod_h2/Manifest
+++ b/www-apache/mod_h2/Manifest
@@ -1 +1,2 @@
DIST mod_h2-2.0.24.tar.gz 689555 BLAKE2B 8fa963a96fb29ba257e4fce072bd7d4bf4e46cfe64f066d9d3a9c692d4bc61552fce3340dd89a0547a6e3dd7180051ce5b0334eae763809e99755441f6203e90 SHA512 1f80c2738f84a58eb691d6a51ed63be4a3567d10501e0fd69aca8519ede8e084b85fb2aad678701b65c6422b6216c005ec8a50199f55e35a1c1197f87dfd5862
+DIST mod_h2-2.0.25.tar.gz 689178 BLAKE2B 4cc8d7ae2aa399c031dadd031e7711a71f73402e5f7e4678fcccc826d5992c2cf08ed009a62ae01ea500de2a63da187ed609aab4128c5054da86e173252f0c85 SHA512 1934e9ec435a8e19cbb0f45dbca5106911e53755d6581f8ca89058bffdc50085f3e0f6ab092ea76a7c203689474fbb81f9d20d8e5fd452bc6b855046f10b85a5
diff --git a/www-apache/mod_h2/mod_h2-2.0.25.ebuild b/www-apache/mod_h2/mod_h2-2.0.25.ebuild
new file mode 100644
index 000000000000..5ba43634b8e0
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-2.0.25.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit apache-module autotools
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-r3
+else
+ MY_PV="${PV/_rc/-rc}"
+ MY_P="${PN}-${MY_PV}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/icing/mod_h2/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ >=www-servers/apache-2.4.48[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}