summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mod_limitipconn
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mod_limitipconn')
-rw-r--r--www-apache/mod_limitipconn/Manifest1
-rw-r--r--www-apache/mod_limitipconn/files/27_mod_limitipconn.conf20
-rw-r--r--www-apache/mod_limitipconn/metadata.xml13
-rw-r--r--www-apache/mod_limitipconn/mod_limitipconn-0.24.ebuild26
4 files changed, 60 insertions, 0 deletions
diff --git a/www-apache/mod_limitipconn/Manifest b/www-apache/mod_limitipconn/Manifest
new file mode 100644
index 000000000000..c281f9db0d4d
--- /dev/null
+++ b/www-apache/mod_limitipconn/Manifest
@@ -0,0 +1 @@
+DIST mod_limitipconn-0.24.tar.bz2 10150 SHA256 69ca8fbf99d4e02db75e129df07d1604db771e9c10c1b199e2accaa96aec2a1f SHA512 caf1337231ac83ef57938b0f89769afcf309a4a09a0a2c3fb171e49f038d42a5859dfdac06b2c7766f05d9431132b8752aa8ad5164794c89638eb90f392e827f WHIRLPOOL 740f0b2901099544f1fc03154ccec9ccac393501c1e5ffa8a3727a5f336cbceb54334174fb7f6b8e46cfdb8d49858b79d47fe6cc3ab056ff5c74826df77e0ad2
diff --git a/www-apache/mod_limitipconn/files/27_mod_limitipconn.conf b/www-apache/mod_limitipconn/files/27_mod_limitipconn.conf
new file mode 100644
index 000000000000..0c3f9d7ed4ae
--- /dev/null
+++ b/www-apache/mod_limitipconn/files/27_mod_limitipconn.conf
@@ -0,0 +1,20 @@
+<IfDefine LIMITIPCONN>
+LoadModule limitipconn_module modules/mod_limitipconn.so
+
+<Location /somewhere>
+ MaxConnPerIP 3
+ # exempting images from the connection limit is often a good
+ # idea if your web page has lots of inline images, since these
+ # pages often generate a flurry of concurrent image requests
+ NoIPLimit image/*
+</Location>
+
+<Location /mp3>
+ MaxConnPerIP 1
+ # In this case, all MIME types other than audio/mpeg and video*
+ # are exempt from the limit check
+ OnlyIPLimit audio/mpeg video
+</Location>
+</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_limitipconn/metadata.xml b/www-apache/mod_limitipconn/metadata.xml
new file mode 100644
index 000000000000..d8d06c3ff5ec
--- /dev/null
+++ b/www-apache/mod_limitipconn/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tomk@gentoo.org</email>
+ <name>Tom Knight</name>
+ </maintainer>
+ <longdescription>
+ Apache module to limit the maximum number of simultaneous
+ connections per IP address. Allows inclusion and exclusion of files
+ based on MIME type.
+ </longdescription>
+</pkgmetadata>
diff --git a/www-apache/mod_limitipconn/mod_limitipconn-0.24.ebuild b/www-apache/mod_limitipconn/mod_limitipconn-0.24.ebuild
new file mode 100644
index 000000000000..c37edbc756c9
--- /dev/null
+++ b/www-apache/mod_limitipconn/mod_limitipconn-0.24.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit apache-module
+
+DESCRIPTION="Allows administrators to limit the number of simultaneous downloads permitted"
+HOMEPAGE="http://dominia.org/djao/limitipconn2.html"
+SRC_URI="http://dominia.org/djao/limit/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+RESTRICT="test"
+
+APACHE2_MOD_CONF="27_${PN}"
+APACHE2_MOD_DEFINE="LIMITIPCONN INFO"
+
+DOCFILES="ChangeLog README"
+
+need_apache2